mplayer aa字符画突然变成了彩色

Totem,mplayer,sopcast,realplayer,bmp
回复
hpr
帖子: 3
注册时间: 2021-07-23 21:39
系统: ubuntu 20.04
送出感谢: 0
接收感谢: 0

mplayer aa字符画突然变成了彩色

#1

帖子 hpr » 2021-07-23 21:59

mplayer aa 终端tty字符画突然变成了彩色

想恢复原来的颜色也就是黑白

而且就是他原本只显示ASCII编码,
现在却会显示些奇奇怪怪的编码.
只有root用户下才会出现这个问题.
但桌面下root用户运行出来的aa for x却仍然是黑白
普通的用户不会出现,
但之前root用户也没有这个问题也是黑白的

注:运行参数和视频文件和以前一模一样
我用的是-vo aa
mplayer -aspect 32:9 -vo aa ./1.flv

求解,谢谢 :Adore
上次由 hpr 在 2021-07-25 20:44,总共编辑 1 次。
头像
astolia
论坛版主
帖子: 5277
注册时间: 2008-09-18 13:11
送出感谢: 1 次
接收感谢: 891 次

Re: mplayer aa字符画突然变成了彩色

#2

帖子 astolia » 2021-07-25 20:37

就是不把用了哪些参数写出来是吧?-vo caca就是彩色的,-vo aa才是黑白
hpr
帖子: 3
注册时间: 2021-07-23 21:39
系统: ubuntu 20.04
送出感谢: 0
接收感谢: 0

Re: mplayer aa字符画突然变成了彩色

#3

帖子 hpr » 2021-07-25 20:41

astolia 写了:
2021-07-25 20:37
就是不把用了哪些参数写出来是吧?-vo caca就是彩色的,-vo aa才是黑白
我用的是-vo aa
mplayer -aspect 32:9 -vo aa ./1.flv
头像
astolia
论坛版主
帖子: 5277
注册时间: 2008-09-18 13:11
送出感谢: 1 次
接收感谢: 891 次

Re: mplayer aa字符画突然变成了彩色

#4

帖子 astolia » 2021-07-25 21:19

mplayer运行后会输出实际使用的参数,你不带文件名或者带个空文件名运行看看
hpr
帖子: 3
注册时间: 2021-07-23 21:39
系统: ubuntu 20.04
送出感谢: 0
接收感谢: 0

Re: mplayer aa字符画突然变成了彩色

#5

帖子 hpr » 2021-07-25 21:24

astolia 写了:
2021-07-25 21:19
mplayer运行后会输出实际使用的参数,你不带文件名或者带个空文件名运行看看
这是我说的情况的运行参数
MPlayer 1.3.0 (Debian), built with gcc-9 (C) 2000-2016 MPlayer Team

Playing 1.flv.
libavformat version 58.29.100 (external)
libavformat file format detected.
[lavf] stream 0: video (h264), -vid 0
[lavf] stream 1: audio (aac), -aid 0
VIDEO: [H264] 1920x1080 0bpp 23.976 fps 3501.4 kbps (427.4 kbyte/s)
[?25l[9;0]==========================================================================
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
libavcodec version 58.54.100 (external)
Selected video codec: [ffh264] vfm: ffmpeg (FFmpeg H.264)
==========================================================================
Clip info:
description: Bilibili VXCode Swarm Transcoder v0.3.73
metadatacreator: Version 1.9
hasKeyframes: true
hasVideo: true
hasAudio: true
hasMetadata: true
canSeekToEnd: true
datasize: 42336094
videosize: 38716699
audiosize: 3594307
lasttimestamp: 88
lastkeyframetimestamp: 88
lastkeyframelocation: 42337081
Load subtitles in ./
==========================================================================
Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
AUDIO: 48000 Hz, 2 ch, floatle, 320.4 kbit/10.43% (ratio: 40046->384000)
Selected audio codec: [ffaac] afm: ffmpeg (FFmpeg AAC (MPEG-2/MPEG-4 Audio))
==========================================================================
[AO SDL] Samplerate: 48000Hz Channels: Stereo Format floatle
[AO SDL] using aalib audio driver.
Audio: no sound
Starting playback...
Movie-Aspect is undefined - no prescaling applied.
VO: [aa] 1920x1080 => 1920x1080 Planar YV12
[swscaler @ 0x7fed8acee000]bicubic scaler, from yuv420p to gray using MMXEXT

Important suboptions
extended use use all 256 characters
eight use eight bit ascii
driver set recommended aalib driver (X11,curses,linux)
help to see all options provided by aalib

AA-MPlayer Keys
1 : contrast -
2 : contrast +
3 : brightness -
4 : brightness +
5 : fast rendering
6 : dithering
7 : invert image
a : toggles between aa and mplayer control
回复