分页: 4 / 5

发表于 : 2007-07-18 21:14
gshangyu
maomaoCSD 写了:编译错误,需安装什么?
错误如下:

gcc: freetype-config --cflags --libs:没有那个文件或目录
In file included from xine-fontconv.c:47:
/usr/include/ft2build.h:56:38: error: freetype/config/ftheader.h: 没有那个文件或目录
xine-fontconv.c:48:10: error: #include expects "FILENAME" or <FILENAME>
xine-fontconv.c:49:10: error: #include expects "FILENAME" or <FILENAME>
xine-fontconv.c:234: 错误:syntax error before ‘*’ token
xine-fontconv.c: 在函数 ‘create_bitmap’ 中:
xine-fontconv.c:235: 错误:‘FT_Bitmap’ 未声明 (在此函数内第一次使用)
xine-fontconv.c:235: 错误:(即使在一个函数内多次出现,每个未声明的标识符在其
xine-fontconv.c:235: 错误:所在的函数内只报告一次。)
xine-fontconv.c:235: 错误:‘bitmap’ 未声明 (在此函数内第一次使用)
xine-fontconv.c: 在顶层:
xine-fontconv.c:249: 错误:syntax error before ‘*’ token
xine-fontconv.c: 在函数 ‘destroy_bitmap’ 中:
xine-fontconv.c:250: 错误:‘bitmap’ 未声明 (在此函数内第一次使用)
xine-fontconv.c: 在顶层:
xine-fontconv.c:262: 错误:syntax error before ‘*’ token
xine-fontconv.c: 在函数 ‘add_border_bitmap’ 中:
xine-fontconv.c:268: 错误:‘src’ 未声明 (在此函数内第一次使用)
xine-fontconv.c:272: 错误:‘left’ 未声明 (在此函数内第一次使用)
xine-fontconv.c:273: 错误:‘dst’ 未声明 (在此函数内第一次使用)
xine-fontconv.c:276: 错误:‘top’ 未声明 (在此函数内第一次使用)
xine-fontconv.c: 在顶层:
xine-fontconv.c:304: 错误:syntax error before ‘*’ token
xine-fontconv.c: 在函数 ‘add_final_bitmap’ 中:
xine-fontconv.c:310: 错误:‘src’ 未声明 (在此函数内第一次使用)
xine-fontconv.c:314: 错误:‘left’ 未声明 (在此函数内第一次使用)
xine-fontconv.c:315: 错误:‘dst’ 未声明 (在此函数内第一次使用)
xine-fontconv.c:318: 错误:‘top’ 未声明 (在此函数内第一次使用)
xine-fontconv.c: 在顶层:
xine-fontconv.c:339: 错误:syntax error before ‘face’
xine-fontconv.c: 在函数 ‘render_font’ 中:
xine-fontconv.c:343: 错误:‘FT_Bitmap’ 未声明 (在此函数内第一次使用)
xine-fontconv.c:343: 错误:‘out_bitmap’ 未声明 (在此函数内第一次使用)
xine-fontconv.c:348: 错误:‘FT_Glyph’ 未声明 (在此函数内第一次使用)
xine-fontconv.c:348: 错误:syntax error before ‘glyph’
xine-fontconv.c:349: 错误:‘FT_BitmapGlyph’ 未声明 (在此函数内第一次使用)
xine-fontconv.c:350: 错误:‘FT_Vector’ 未声明 (在此函数内第一次使用)
xine-fontconv.c:366: 错误:‘fontname’ 未声明 (在此函数内第一次使用)
xine-fontconv.c:366: 错误:‘size’ 未声明 (在此函数内第一次使用)
xine-fontconv.c:389: 错误:‘face’ 未声明 (在此函数内第一次使用)
xine-fontconv.c:398: 错误:‘thickness’ 未声明 (在此函数内第一次使用)
xine-fontconv.c:408: 错误:‘unicodes’ 未声明 (在此函数内第一次使用)
xine-fontconv.c:419: 错误:‘FT_LOAD_DEFAULT’ 未声明 (在此函数内第一次使用)
xine-fontconv.c:458: 错误:‘glyph’ 未声明 (在此函数内第一次使用)
xine-fontconv.c:466: 错误:‘origin’ 未声明 (在此函数内第一次使用)
xine-fontconv.c:470: 错误:‘ft_render_mode_normal’ 未声明 (在此函数内第一次使用)
xine-fontconv.c:478: 错误:‘glyph_bitmap’ 未声明 (在此函数内第一次使用)
xine-fontconv.c:478: 错误:syntax error before ‘glyph’
xine-fontconv.c: 在函数 ‘main’ 中:
xine-fontconv.c:533: 错误:‘FT_Library’ 未声明 (在此函数内第一次使用)
xine-fontconv.c:533: 错误:syntax error before ‘library’
xine-fontconv.c:534: 错误:‘FT_Face’ 未声明 (在此函数内第一次使用)
xine-fontconv.c:559: 错误:‘library’ 未声明 (在此函数内第一次使用)
xine-fontconv.c:568: 错误:‘face’ 未声明 (在此函数内第一次使用)
xine-fontconv.c:573: 错误:‘ft_encoding_unicode’ 未声明 (在此函数内第一次使用)
你应该是没有装libfreetype6-dev这个工具吧
装上了就好了
但我最后出现了跟39楼一样的问题
不知道又是缺少了哪个软件

直接安装xine字体就行了

发表于 : 2007-08-20 21:49
liangkou
中文字幕的 deb 包
http://ftp.ubuntu.org.cn/fonts/xine-fonts-cn/
xine-fonts-cn_0.1.2_all.deb
下载后安装就可以了。
我装后就能用totem看mkv格式的friends,有中文字幕。

发表于 : 2008-01-09 18:18
command
内存不足 写了:還是用mplayer方便.idx+.sub的字幕可以看了,但在加载的时候有个弹出窗口说.sub什么的。
我的问题和你的一样,怎么才能消灭那个烦心的提示呢?

发表于 : 2008-01-18 0:18
petepete
下载并安装了中文字体,字幕反而都不出来了(以前有的,却是XXXX)
我的ubuntu没有totem_config文件,只有xine_config
字幕部分配置如下:
# subtitle size
# { tiny small normal large very large huge }, default: 1
subtitles.separate.subtitle_size:normal

# subtitle vertical offset
# numeric, default: 0
subtitles.separate.vertical_offset:30

# font for subtitles
# string, default: sans
subtitles.separate.font:sans

# font for subtitles
# string, default:
#subtitles.separate.font_freetype:

# whether to use a freetype font
# bool, default: 0
subtitles.separate.font_use_freetype:30

# encoding of the subtitles
# string, default: iso-8859-1
subtitles.separate.src_encoding:gb18030
totem xine player 字幕部分设置为:
font: sans
encoding: GB18030
---
该如何解决?
该如何修改?
:oops:

发表于 : 2008-01-18 2:34
dorice
下载安装deb包之后,会把原来的字体文件删除……
而且中文还是乱码,折腾不起了,用iconv转换成utf8了……
怀疑新版的设置变了

发表于 : 2008-01-18 10:53
artistf
05n年的帖子这么靠上 啊?!

发表于 : 2008-03-02 10:55
189wxg
[email protected]:~$ sudo apt-get source libxine1c2
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
E: 无法打开文件 /var/lib/apt/lists/mirror.vmmatrix.net_ubuntu_dists_gutsy_main_source_Sources - open (2 No such file or directory)

发表于 : 2008-04-28 23:27
Joshua_Zhan
8.04里好像没有~/.gnome2/totem_config文件啊,8.04里该到哪找这个配置文件啊

发表于 : 2008-06-21 1:37
Duke.Augustine
请问8.04LTS的用户应该怎么改阿?

发表于 : 2008-06-21 19:35
kississik
Joshua_Zhan 写了:8.04里好像没有~/.gnome2/totem_config文件啊,8.04里该到哪找这个配置文件啊
~/.gnome2/Totem/totem_config

发表于 : 2008-06-25 19:48
飘迹
谢谢,感激不尽!
解决了我的问题!

发表于 : 2008-07-02 23:04
Duke.Augustine
kississik 写了:
Joshua_Zhan 写了:8.04里好像没有~/.gnome2/totem_config文件啊,8.04里该到哪找这个配置文件啊
~/.gnome2/Totem/totem_config
THX:)

发表于 : 2008-09-13 2:15
emlary
我也是用的ubuntu8.04怎么就没有上面说的目录呢?
~/.gnome2/Totem/totem_config

出错!!

发表于 : 2008-10-14 9:41
chaosriver
没有目录?

报错如下:
读取状态信息... 完成
E: 无法打开文件 /var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_breezy_main_source_Sources - open (2 没有该文件或目录)
[email protected]:~$ cd xine-lib-1.0.1/misc/
bash: cd: xine-lib-1.0.1/misc/: 没有该文件或目录

难道是我有东西没装吗?

Re: totem-xine 的中文字幕处理。

发表于 : 2008-10-20 13:09
daggerman
俺的8.04也没有这个目录gnome2 , 只有一个gnome。而且里面没有这个配置文件。全盘搜索都木有! :em06
郁闷! :em20