求助啊,各位大神,,,执行”grub-install/dev/sda”有误

系统安装、升级讨论
版面规则
我们都知道新人的确很菜,也喜欢抱怨,并且带有浓厚的Windows习惯,但既然在这里询问,我们就应该有责任帮助他们解决问题,而不是直接泼冷水、简单的否定或发表对解决问题没有任何帮助的帖子。乐于分享,以人为本,这正是Ubuntu的精神所在。
回复
fkcong
帖子: 3
注册时间: 2016-04-07 17:20
系统: win10
送出感谢: 1 次
接收感谢: 0

求助啊,各位大神,,,执行”grub-install/dev/sda”有误

#1

帖子 fkcong » 2016-04-07 17:28

小弟想在我win10的电脑上安装Ubuntu,按着网上的步骤来,却出现问题,执行”grub-install/dev/sda”有误,这是为什么啊,哪位大神能帮忙解决,感激不尽~
附件
IMG_20160406_131356_AO_HDR.jpg
照的图片
sulit
帖子: 21
注册时间: 2011-12-08 17:35
送出感谢: 1 次
接收感谢: 2 次

Re: 求助啊,各位大神,,,执行”grub-install/dev/sda”有误

#2

帖子 sulit » 2016-04-07 17:47

重装,如果还出现这个问题,把你所有的操作,还有你的电脑信息,系统信息都贴出来
这些用户感谢了作者 sulit 于这个帖子:
fkcong (2016-04-07 18:23)
评价: 3.7%
fkcong
帖子: 3
注册时间: 2016-04-07 17:20
系统: win10
送出感谢: 1 次
接收感谢: 0

Re: 求助啊,各位大神,,,执行”grub-install/dev/sda”有误

#3

帖子 fkcong » 2016-04-07 18:32

sulit 写了:重装,如果还出现这个问题,把你所有的操作,还有你的电脑信息,系统信息都贴出来
重装了两三次,还是这个问题,,,我最开始装的是Ubuntu的优麒麟,装成功了,然后卡住动不了,我强制关机,然后再也进不了Ubuntu,开机直接进入win10,然后下了个easyBCD,添加了个linux开机启动,但是也没用,进不去,没办法,我从磁盘管理里面把优麒麟在的几个分区直接删除,后来安装Ubuntu14.04.1,然后就出现上面的问题了,试了几次,都不行,我是用ultralso把镜像弄到u盘,u盘进行安装的
poloshiao
论坛版主
帖子: 18280
注册时间: 2009-08-04 16:33
送出感谢: 21 次
接收感谢: 1957 次

Re: 求助啊,各位大神,,,执行”grub-install/dev/sda”有误

#4

帖子 poloshiao » 2016-04-08 9:32

我win10的电脑上安装Ubuntu,按着网上的步骤来
請提供該參考安裝網頁的網址上來
头像
lainme
论坛版主
帖子: 7805
注册时间: 2008-09-13 19:17
系统: Arch Linux (x86_64)
送出感谢: 3 次
接收感谢: 69 次
联系:

Re: 求助啊,各位大神,,,执行”grub-install/dev/sda”有误

#5

帖子 lainme » 2016-04-08 10:33

把 运行“grub-install ..."那行字前面的符号点开,可以看到终端输出,一般能得到更详细的报错信息
fkcong
帖子: 3
注册时间: 2016-04-07 17:20
系统: win10
送出感谢: 1 次
接收感谢: 0

Re: 求助啊,各位大神,,,执行”grub-install/dev/sda”有误

#6

帖子 fkcong » 2016-04-08 11:41

poloshiao 写了:
我win10的电脑上安装Ubuntu,按着网上的步骤来
請提供該參考安裝網頁的網址上來
这是那个网址,http://os.51cto.com/art/201405/439158.htm,您看看有什么问题
poloshiao
论坛版主
帖子: 18280
注册时间: 2009-08-04 16:33
送出感谢: 21 次
接收感谢: 1957 次

Re: 求助啊,各位大神,,,执行”grub-install/dev/sda”有误

#7

帖子 poloshiao » 2016-04-08 12:05

图片

1. 安裝到這個畫面 你選擇哪一個

图片

2. 安裝到這個畫面 最下方的 Device for boot loader installation 你選擇哪一個
sulit
帖子: 21
注册时间: 2011-12-08 17:35
送出感谢: 1 次
接收感谢: 2 次

Re: 求助啊,各位大神,,,执行”grub-install/dev/sda”有误

#8

帖子 sulit » 2016-04-08 12:29

好了,不要那么费事了,用U盘启动,进入livecd环境,把安装分区挂载到某个目录,在这个目录下执行如下命令(用sudo,或者root)
mount -B /dev dev
mount -B /proc proc
mount -B /sys sys
chroot .
grub-install /dev/sda
然后看有什么错,如果能执行成功,那就可以用ubuntu了,如果执行失败,把错误的内容贴出来
mobox
帖子: 1
注册时间: 2010-09-30 16:39
送出感谢: 0
接收感谢: 0

Re: 求助啊,各位大神,,,执行”grub-install/dev/sda”有误

#9

帖子 mobox » 2021-05-15 10:48

我也遇到类似问题的 ,好像按方法做,没有测试通啊
头像
sunfish
帖子: 972
注册时间: 2008-05-03 1:53
送出感谢: 18 次
接收感谢: 9 次
联系:

Re: 求助啊,各位大神,,,执行”grub-install/dev/sda”有误

#10

帖子 sunfish » 2021-05-15 17:19

wsl2也挺好用的,也可以安装ubuntu桌面
docker && kubernetes
pang15975386
帖子: 143
注册时间: 2011-05-16 18:00
送出感谢: 4 次
接收感谢: 4 次

Re: 求助啊,各位大神,,,执行”grub-install/dev/sda”有误

#11

帖子 pang15975386 » 2021-05-15 20:50

可以尝试用英文安装,反正server版用英文安装没问题,反倒是中文安装会卡到"grub install"这步,14.04是没这个问题的,16.04之后的版本都有个这个问题(server 版)
fuhuizn
帖子: 903
注册时间: 2006-01-06 22:55
系统: ubuntu
送出感谢: 0
接收感谢: 23 次
联系:

Re: 求助啊,各位大神,,,执行”grub-install/dev/sda”有误

#12

帖子 fuhuizn » 2021-05-16 11:37

uefi启动条目太多了,可能需要删除一下启动条目。
如果是双系统,安装完ubuntu后可以在windows里面用easyuefi建立ubuntu的启动条目。

如果只有ubuntu,可以用efibootmgr删除多余的启动条目,下面的页面是百度到的一个简单的示例:
http://bbs.wuyou.net/forum.php?mod=view ... tid=348421
头像
daf3707
论坛版主
帖子: 12701
注册时间: 2007-06-13 15:57
来自: 在他乡
送出感谢: 52 次
接收感谢: 85 次

Re: 求助啊,各位大神,,,执行”grub-install/dev/sda”有误

#13

帖子 daf3707 » 2021-05-18 13:54

我用测试版21.04时最后也是这个,导致在grub进不了。。。正式版就不存在了...
回复

回到 “系统安装和升级”