用的是 unstable 发行版, 如何解决?

系统安装、升级讨论
版面规则
我们都知道新人的确很菜,也喜欢抱怨,并且带有浓厚的Windows习惯,但既然在这里询问,我们就应该有责任帮助他们解决问题,而不是直接泼冷水、简单的否定或发表对解决问题没有任何帮助的帖子。乐于分享,以人为本,这正是Ubuntu的精神所在。
回复
yueli711
帖子: 99
注册时间: 2013-05-28 23:34
系统: ubuntu
送出感谢: 0
接收感谢: 1 次

用的是 unstable 发行版, 如何解决?

#1

帖子 yueli711 » 2021-06-16 12:47

各位大侠,

下面这个问题如何解决?

先谢谢!

yue


root@Ph:/home/dongh# apt-get install libssl-dev
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
正在读取状态信息... 完成
有一些软件包无法被安装。如果您用的是 unstable 发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们已被从新到(Incoming)目录移出。
下列信息可能会对解决问题有所帮助:

下列软件包有未满足的依赖关系:
libssl-dev : 依赖: libssl1.1 (= 1.1.1-1ubuntu2.1~18.04.9) 但是 1.1.1f-1ubuntu2.3 正要被安装
E: 无法修正错误,因为您要求某些软件包保持现状,就是它们破坏了软件包间的依赖关系。
yueli711
帖子: 99
注册时间: 2013-05-28 23:34
系统: ubuntu
送出感谢: 0
接收感谢: 1 次

Re: 用的是 unstable 发行版, 如何解决?

#2

帖子 yueli711 » 2021-06-16 14:14

sudo gedit /etc/apt/sources.list

该ubuntu20.04.1的代码全部为focal
头像
astolia
论坛版主
帖子: 5208
注册时间: 2008-09-18 13:11
送出感谢: 1 次
接收感谢: 880 次

Re: 用的是 unstable 发行版, 如何解决?

#3

帖子 astolia » 2021-06-16 17:09

yueli711 写了:
2021-06-16 12:47
有一些软件包无法被安装。如果您用的是 unstable 发行版,这也许是
语文要学好,如果是做假设,不是陈述事实
yueli711 写了:
2021-06-16 12:47
libssl-dev : 依赖: libssl1.1 (= 1.1.1-1ubuntu2.1~18.04.9) 但是 1.1.1f-1ubuntu2.3 正要被安装
E: 无法修正错误,因为您要求某些软件包保持现状,就是它们破坏了软件包间的依赖关系。
1.1.1-1ubuntu2.1~18.04.9是18.04里的版本,就算你是从18.04升级上来的,正常情况下也都一并升级到1.1.1f-1ubuntu2.3了。是你用apt-mark锁定了版本还是怎么搞的就只有你自己清楚了。
回复

回到 “系统安装和升级”