[问题]ubuntu真实终端显示乱码

系统安装、升级讨论
scofielg
帖子: 4
注册时间: 2010-11-15 11:52
送出感谢: 0
接收感谢: 0

Re: [问题]ubuntu真实终端显示乱码

#16

帖子 scofielg » 2011-05-17 9:49

额...
安装完zhcon后. 在真实终端(Ctrl+Alt+F1). root权限下输入zhcon --utf8. 终端就支持中文了.
很完美呀.
funicorn
帖子: 1131
注册时间: 2005-09-13 4:56
系统: Ubuntu QQ
送出感谢: 0
接收感谢: 47 次

Re: [问题]ubuntu真实终端显示乱码

#17

帖子 funicorn » 2011-05-17 10:21

安装zhcon,tty下运行
$ env LANG=zh_CN.utf8 zhcon --utf8
回车,试试看
添加ppa后只更新此ppa:
update-ppa()
{ sudo apt-get update -o Dir::Etc::sourcelist="sources.list.d/$1.list" -o Dir::Etc::sourceparts="-" -o APT::Get::List-Cleanup="0"
}
写入~/.bashrc,source一下,就可以直接用,是不是很方便?觉得方便就按个赞。
hacker85
帖子: 557
注册时间: 2010-02-25 11:19
送出感谢: 0
接收感谢: 0

Re: Re:

#18

帖子 hacker85 » 2013-03-28 21:17

marble 写了:
JiangHui 写了:sudo apt-get install zhcon
zhcon --uft8 --drv=vga
如果开了framebuffer,可以
zhcon --utf8 --drv=fb
如果我用用zhcon --utf8 --drv=fb,就会提示Can not open FrameBuffer device on this device,然后下面是
============== I'm really sorry, but... ================
I can not open graphical device on this machine, this can happen when:
1. your kernel does not have framebuffer device enabled, check the output from `dmesg|grep vesa`
2. you are running on a non-i386 machine so no VGA support
3. you are running under X-Window but libggi is not compiled in (required for running zhcon under X-Window)
……
如果我用zhcon --utf8 --drv=vga,就直接I'm sorry了,这事咋回事呢?
难道是我的AMD64和宽屏的问题?
我的系统也是AMD64,宽屏。
我在今天也是这种情况,现在有解决办法了吗?
hacker85
帖子: 557
注册时间: 2010-02-25 11:19
送出感谢: 0
接收感谢: 0

Re: [问题]ubuntu真实终端显示乱码

#19

帖子 hacker85 » 2013-03-28 21:21

scofielg 写了:额...
安装完zhcon后. 在真实终端(Ctrl+Alt+F1). root权限下输入zhcon --utf8. 终端就支持中文了.
很完美呀.

用这个方法后汉字都显示成问号了。
hacker85
帖子: 557
注册时间: 2010-02-25 11:19
送出感谢: 0
接收感谢: 0

Re: [问题]ubuntu真实终端显示乱码

#20

帖子 hacker85 » 2013-03-29 9:13

funicorn 写了:添加ppa后只更新此ppa:
1、你这个是函数还是什么?具体怎么使用?

2、你这个方法对于 哪种PPA添加形式是有效的? 是直接写/etc/s.....文件的形式,还是在终端里用命令添加的形式
回复

回到 “系统安装和升级”