無法將GRUB安裝在/dev/nvme0n1

系统安装、升级讨论
版面规则
我们都知道新人的确很菜,也喜欢抱怨,并且带有浓厚的Windows习惯,但既然在这里询问,我们就应该有责任帮助他们解决问题,而不是直接泼冷水、简单的否定或发表对解决问题没有任何帮助的帖子。乐于分享,以人为本,这正是Ubuntu的精神所在。
回复
行走之間
帖子: 108
注册时间: 2009-06-14 19:01
送出感谢: 0
接收感谢: 0

無法將GRUB安裝在/dev/nvme0n1

#1

帖子 行走之間 » 2019-07-20 14:36

請教:安裝如下多個版本均出現如圖提示,如何解決?

Ubuntu 19.04
Kubuntu 18.04
Kubuntu 18.04.2
Kubuntu 19.04
Debian 10.0.0

另外,i386的機子可以裝AMD 64位系統吧?
附件
268859908.jpg
头像
astolia
论坛版主
帖子: 4591
注册时间: 2008-09-18 13:11
送出感谢: 1 次
接收感谢: 767 次

Re: 無法將GRUB安裝在/dev/nvme0n1

#2

帖子 astolia » 2019-08-02 23:30

行走之間 写了:
2019-07-20 14:36
請教:安裝如下多個版本均出現如圖提示,如何解決?
如果系统上已经有了esp分区(比如已经装了一个windows系统),那么要选和Windows Boot Manager共存的选项。如果没出现这个选项,则可能是分区存在错误,需要做磁盘检查

代码: 全选

sudo dosfsck -t -a -w /dev/nvme0n1p1
因为esp一般是第一个分区,所以是p1,如果是其他的分区或硬盘,请根据情况自行修改
行走之間 写了:
2019-07-20 14:36
另外,i386的機子可以裝AMD 64位系統吧?
看你cpu型号。不过10年内出的cpu都可以用amd64。不支持的话安装前会提示的
回复

回到 “系统安装和升级”