关于百度网盘版本问题,不知是百度那边软件的问题还是安装包OR Ubuntu的,总之,走过路过,求指教一波

系统安装、升级讨论
回复
K_Y
帖子: 1
注册时间: 2020-01-06 22:49
系统: ubuntu18.4
送出感谢: 0
接收感谢: 0

关于百度网盘版本问题,不知是百度那边软件的问题还是安装包OR Ubuntu的,总之,走过路过,求指教一波

#1

帖子 K_Y » 2020-01-07 21:02

2020-01-07 20-45-17 的屏幕截图.png
2020-01-07 20-44-37 的屏幕截图.png
2020-01-07 20-43-17 的屏幕截图.png
如上图:百度官网下载的deb包,说是3.0.1.然后我下载安装之后显示的也的确是3.0.1版本,但是在百度网盘的这个软件里面查看的版本信息却是2.0.1,这就让我产生疑惑了。也不知在哪儿看到的一个信息,说是apt-get安装的本地deb包会搜索ubuntu软件仓库的对应的包,然后会安装ubuntu仓库的包,从而忽略本地的deb包。当然,这个我也不是很确定,所以,有懂的朋友,解释一波再走可好。所以呢,这事儿,是啥情况,是哪一方的问题,我?百度?ubuntu?
[color=#FF00FF]空山幽谷静,龙吟天地间。[/color]
头像
astolia
论坛版主
帖子: 4406
注册时间: 2008-09-18 13:11
送出感谢: 1 次
接收感谢: 738 次

Re: 关于百度网盘版本问题,不知是百度那边软件的问题还是安装包OR Ubuntu的,总之,走过路过,求指教一波

#2

帖子 astolia » 2020-01-07 22:19

软件安装包的版本信息和软件的版本信息是在不同的文件里,内容不一致没什么大不了的,只是说明软件开发者/打包者中至少有一个傻X。
它软件的代码里也没把到底是3.0.1还是2.0.3整统一,看起来开发者傻X的概率要高些
b.png
a.png
有强迫症的话,自己把opt/baidunetdisk/resources/app.asar解包出来,手动修改dist/electron/下面的main.js和renderer.js,把类似图2代码中出现的版本号改对,再打包回去就行
回复

回到 “系统安装和升级”