ubuntu源中的fcitx5已经可用了!!!

系统字体配置、中文显示和输入法问题
回复
zrqlx126
帖子: 268
注册时间: 2007-06-22 18:52
送出感谢: 0
接收感谢: 28 次

ubuntu源中的fcitx5已经可用了!!!

#1

帖子 zrqlx126 » 2020-11-24 18:16

之前发过一篇在ubuntu20.10中安装fcitx5的文章,viewtopic.php?f=8&t=491625,再次测试21.04每日构建版本,发现已经可用了,虽然可用的输入法依然不多,但是已经非常不错了。
fcitx5.png
步骤如下:
1.更新软件源

代码: 全选

sudo apt update
2.安装fcitx5

代码: 全选

sudo apt install fcitx5 fcitx5-pinyin fcitx5-frontend-gtk2 fcitx5-frontend-gtk3 fcitx5-chinese-addons -y
3.给X会话添加环境变量,使fcitx5自启动,覆盖im-config设置

代码: 全选

sudo tee /etc/X11/Xsession.d/73fcitx5_start > /dev/null << 'EOF'
#!/bin/sh

if [ -x /usr/bin/fcitx5 ] && [ -x /usr/bin/im-config ]; then
        if [ ! -f $HOME/.xinputrc ]; then
                /usr/bin/im-config -n fcitx5 && export XMODIFIERS=@im=fcitx || true
        fi

        if [ "$XMODIFIERS" = "@im=fcitx" ]; then
                if [ -f /usr/lib/*/gtk-2.0/*/immodules/im-fcitx5.so ] && [ -f /usr/lib/*/gtk-3.0/*/immodules/im-fcitx5.so ]; then
                        export GTK_IM_MODULE=fcitx
                fi
                if [ -f /usr/lib/*/qt4/plugins/inputmethods/qtim-fcitx5.so ]; then
                        export QT4_IM_MODULE=fcitx
                fi
                if [ -f /usr/lib/*/qt5/plugins/platforminputcontexts/libfcitx5platforminputcontextplugin.so ]; then
                        export QT_IM_MODULE=fcitx
                fi
        fi
        if [ -x /usr/bin/fcitx5-remote ]; then
                /usr/bin/fcitx5-remote > /dev/null || /usr/bin/fcitx5
        fi
        if [ -x /usr/bin/im-launch ]; then
                STARTUP="/usr/bin/im-launch $STARTUP"
        fi
fi
EOF
# 给予一般文件权限
sudo chmod 0644 /etc/X11/Xsession.d/73fcitx5_start
4.清空原系统输入法列表。这里全部予以删除,避免出现干扰

代码: 全选

gsettings set org.gnome.desktop.input-sources sources "[]"
gsettings set org.gnome.desktop.input-sources mru-sources "[('xkb', 'cn')]"
5.安装并启用gnome-shell-extension-kimpanel扩展

代码: 全选

wget https://extensions.gnome.org/extension-data/kimpanelkde.org.v55.shell-extension.zip
gnome-extensions install kimpanelkde.org.v55.shell-extension.zip
gnome-extensions enable kimpanel@kde.org
6.选择fcitx5输入法,并重启确保环境变量生效

代码: 全选

im-config -n fcitx
sudo reboot
zrqlx126
帖子: 268
注册时间: 2007-06-22 18:52
送出感谢: 0
接收感谢: 28 次

Re: ubuntu源中的fcitx5已经可用了!!!

#2

帖子 zrqlx126 » 2020-11-25 11:32

针对wps,在最新的版本中,由于环境变量的原因,fcitx5无法激活。可以使用以下方法临时性修复:

代码: 全选

# 注意,这个将几乎废弃的QT4_IM_MODULE变量设置为ibus,然后启动相应组建。
# 启动wps文字
export QT4_IM_MODULE=ibus && /usr/bin/wps
# 启动wps演示
export QT4_IM_MODULE=ibus && /usr/bin/wpp
# 启动wps表格
export QT4_IM_MODULE=ibus && /usr/bin/et
或者将原帖中第3步中

代码: 全选

                if [ -f /usr/lib/*/qt4/plugins/inputmethods/qtim-fcitx5.so ]; then
                        export QT4_IM_MODULE=fcitx
                fi
修改为

代码: 全选

export QT4_IM_MODULE=ibus
2020-11-25 11-49-29屏幕截图.png
头像
zzugyl
帖子: 318
注册时间: 2011-03-07 17:26
系统: Ubuntu 20.04.2 LTS
送出感谢: 3 次
接收感谢: 10 次

Re: ubuntu源中的fcitx5已经可用了!!!

#3

帖子 zzugyl » 2020-11-28 16:29

rime和搜狗能用的话,基本就大功告成了
常在深闺人未识 一朝成名天下知
头像
男菜鸟
帖子: 1302
注册时间: 2008-12-16 14:01
来自: 漂在江湖
送出感谢: 18 次
接收感谢: 17 次

Re: ubuntu源中的fcitx5已经可用了!!!

#4

帖子 男菜鸟 » 2020-12-01 22:55

mark
头像
百草谷居士
帖子: 3649
注册时间: 2006-02-10 16:36
系统: ubuntu20.04/Win10
送出感谢: 34 次
接收感谢: 41 次
联系:

Re: ubuntu源中的fcitx5已经可用了!!!

#5

帖子 百草谷居士 » 2021-06-29 17:17

zzugyl 写了:
2020-11-28 16:29
rime和搜狗能用的话,基本就大功告成了
今天在虚拟机里的xubuntu21.04上安装了fcitx5,基本情况如下:
1、fcitx和fcitx5可以同时安装,没有安装冲突。但是,只能激活一个。可以使用im-config选择fcitx或者fcitx5。
2、fcitx5有对应的rime输入法 fcitx5-rime 。但是我在 .config/fcitx 文件夹下没有找到 rime 配置文件夹,不知道配置文件在哪儿。测试可以使用,因为无法自定义,没有做进一步测试。
3、搜狗输入法依赖 fcitx ,必须在选择使用 fcitx 的情况下才能使用。
Xubuntu 21.04 / 深度系统 20.2

为何热衷于搞发行版的多,搞应用程序开发的少?Linux最多余的就是各种发行版,最缺的就是应用程序,特别是行业应用程序。
头像
百草谷居士
帖子: 3649
注册时间: 2006-02-10 16:36
系统: ubuntu20.04/Win10
送出感谢: 34 次
接收感谢: 41 次
联系:

Re: ubuntu源中的fcitx5已经可用了!!!

#6

帖子 百草谷居士 » 2021-07-03 15:09

今天继续测试,配置文件在 ~/.local/share/fcitx5/rime/ 文件夹下。
可以进行修改自定义,可以导入用户词组。基本可用。
lua 插件不可用,当前日期时间输入不了,也许是我搞错了。
Xubuntu 21.04 / 深度系统 20.2

为何热衷于搞发行版的多,搞应用程序开发的少?Linux最多余的就是各种发行版,最缺的就是应用程序,特别是行业应用程序。
头像
百草谷居士
帖子: 3649
注册时间: 2006-02-10 16:36
系统: ubuntu20.04/Win10
送出感谢: 34 次
接收感谢: 41 次
联系:

Re: ubuntu源中的fcitx5已经可用了!!!

#7

帖子 百草谷居士 » 2021-07-13 9:55

今天发现,新版的fcitx5无法在 为知笔记中使用
Xubuntu 21.04 / 深度系统 20.2

为何热衷于搞发行版的多,搞应用程序开发的少?Linux最多余的就是各种发行版,最缺的就是应用程序,特别是行业应用程序。
Liu, Yihui
帖子: 2
注册时间: 2021-07-31 20:29
系统: KUbuntu
送出感谢: 0
接收感谢: 0

Re: ubuntu源中的fcitx5已经可用了!!!

#8

帖子 Liu, Yihui » 2021-07-31 20:40

我也是前两天装的双系统,只不过是KUbuntu,装上了fcitx5,在浏览器,终端,文本编辑器,wps等地方都使用正常。但是在网易云音乐和ICQ new使用有问题
Liu, Yihui
帖子: 2
注册时间: 2021-07-31 20:29
系统: KUbuntu
送出感谢: 0
接收感谢: 0

Re: ubuntu源中的fcitx5已经可用了!!!

#9

帖子 Liu, Yihui » 2021-08-01 17:15

Liu, Yihui 写了:
2021-07-31 20:40
我也是前两天装的双系统,只不过是KUbuntu,装上了fcitx5,在浏览器,终端,文本编辑器,wps等地方都使用正常。但是在网易云音乐和ICQ new使用有问题
测试了很多linux下的聊天软件,QQ,Wechat,米聊,ICQ new 最后发现在KUbuntu上竟然竞争对手skype的客户端的语音,视频,输入法是正常使用的,简直快泪目了 :Cry ,EDGE也是好评,体验了就知道
YongshengLi
帖子: 1
注册时间: 2021-08-19 17:58
系统: Ubuntu
送出感谢: 0
接收感谢: 0

Re: ubuntu源中的fcitx5已经可用了!!!

#10

帖子 YongshengLi » 2021-08-19 18:04

好消息
回复

回到 “中文支持”