Error while loading shared libraries: libstdc++-libc6.1-1.so.2

为当前最终发行版之前的所有版本提供支持
回复
yueli711
帖子: 71
注册时间: 2013-05-28 23:34
系统: ubuntu
送出感谢: 0
接收感谢: 0

Error while loading shared libraries: libstdc++-libc6.1-1.so.2

#1

帖子 yueli711 » 2019-04-12 7:01

各位大侠,

在跑一条程序的时候遇到的错误:

$ ./AlignACE -j GAL.orf -y -e
./AlignACE: error while loading shared libraries: libstdc++-libc6.1-1.so.2: cannot open shared object file: No such file or directory


我的版本是:

cat /proc/version:


Linux version 3.16.0-73-generic (buildd@lcy01-32) (gcc version 4.8.4 (Ubuntu 4.8.4-2ubuntu1~14.04.3) ) #95~14.04.1-Ubuntu SMP Thu Jun 9 08:00:04 UTC 2016


先谢谢了!


yue
头像
astolia
论坛版主
帖子: 3686
注册时间: 2008-09-18 13:11
送出感谢: 1 次
接收感谢: 618 次

Re: Error while loading shared libraries: libstdc++-libc6.1-1.so.2

#2

帖子 astolia » 2019-04-12 15:54

从debian上弄来 http://archive.debian.org/debian/pool/m ... 4_i386.deb 装上,里面就有libstdc++-libc6.1-1.so.2,你可以先试试。
快20年前的程序了,不管是linux还是gcc都变了很多,不要有太大希望。
它还有个win版的程序,你可以用wine来跑或者直接到win上去运行
yueli711
帖子: 71
注册时间: 2013-05-28 23:34
系统: ubuntu
送出感谢: 0
接收感谢: 0

Re: Error while loading shared libraries: libstdc++-libc6.1-1.so.2

#3

帖子 yueli711 » 2019-04-12 22:38

非常感谢!
回复

回到 “老旧版本支持”