无法安装WPS软件

为当前最终发行版之前的所有版本提供支持
回复
头像
Yang7Ke
帖子: 6
注册时间: 2019-07-17 15:04
系统: Ubuntu 18.04.2
送出感谢: 0
接收感谢: 0

无法安装WPS软件

#1

帖子 Yang7Ke » 2019-08-02 17:29

我想在Ubuntu19.04上安装WPS,之前自己去WPS社区下载安装包,安装之后用的不爽(无法拉动边缘进行窗口缩放)
所以我就把安装的文件删除了

然后我就去软件中心安装WPS,但是安装不了了,出现如下报错:
has"install-snap"change in progress

而且软件中心的窗口又变回install界面,非launch界面,如附件中的图示。

我当时根据报错内容进行了搜索,想强行停止snap,但出现with nothing pending的报错,如下所示:
[email protected]:~$ snap changes
ID Status Spawn Ready Summary
7 Error today at 08:17 CST today at 08:43 CST Install "wps-office-multilang" snap
8 Error today at 08:49 CST today at 08:57 CST Install "wps-office-all-lang-no-internet" snap
9 Error today at 11:03 CST today at 11:08 CST Install "wps-office-multilang" snap
[email protected]:~$ snap abort 7
error: cannot abort change 7 with nothing pending
[email protected]:~$ snap abort 8
error: cannot abort change 8 with nothing pending
[email protected]:~$ snap abort 9
error: cannot abort change 9 with nothing pending

那么我该如何解决这个报错,然后安装好WPS呢
附件
Screenshot from 2019-08-02 17-16-53.png
头像
astolia
论坛版主
帖子: 4802
注册时间: 2008-09-18 13:11
送出感谢: 1 次
接收感谢: 808 次

Re: 无法安装WPS软件

#2

帖子 astolia » 2019-08-02 22:27

那些已经是error状态了,不能也不需要abort
我记得snap安装时会先去获取一份需要的文件列表(相当于apt update),你应该是卡在这上面了。
你需要让snapd通过一个https代理来下载,可以在/etc/environment里加一行https_proxy=http://abcd,并保证位于abcd的代理服务器能代理往snapcraft.io的请求,然后重启snapd让它用新的环境变量。

代码: 全选

sudo systemctl restart snapd
hacker85
帖子: 567
注册时间: 2010-02-25 11:19
送出感谢: 1 次
接收感谢: 0

Re: 无法安装WPS软件

#3

帖子 hacker85 » 2019-08-17 11:44

astolia 写了:
2019-08-02 22:27
那些已经是error状态了,不能也不需要abort
你的意思是这些error根本就不需要管了呗? 也不影响什么
在18.04上,我再次键入snap install packgename 还是可以正常安装的,只不过是从0%开始,过程很慢,不挂代理的话

似乎这个error不影响到什么
回复

回到 “其他版本支持”