ubuntu如何解决无法修正错误的依赖问题

为当前最终发行版之前的所有版本提供支持
回复
freshman007
帖子: 7
注册时间: 2019-09-22 15:24
系统: Ubuntu
送出感谢: 1 次
接收感谢: 0

ubuntu如何解决无法修正错误的依赖问题

#1

帖子 freshman007 » 2019-09-23 16:39

例如当我要 sudo apt-get install gcc-multilib 时
却出现了以下报错信息

正在读取软件包列表... 完成
正在分析软件包的依赖关系树
正在读取状态信息... 完成
有一些软件包无法被安装。如果您用的是 unstable 发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们已被从新到(Incoming)目录移出。
下列信息可能会对解决问题有所帮助:

下列软件包有未满足的依赖关系:
gcc-multilib : 依赖: gcc-7-multilib (>= 7.3.0-27~) 但是它将不会被安装
E: 无法修正错误,因为您要求某些软件包保持现状,就是它们破坏了软件包间的依赖关系。
freshman007
帖子: 7
注册时间: 2019-09-22 15:24
系统: Ubuntu
送出感谢: 1 次
接收感谢: 0

Re: ubuntu如何解决无法修正错误的依赖问题

#2

帖子 freshman007 » 2019-09-23 16:50

已解决!只要通过在 软件和更新 里更换下载合适的下载源
回复

回到 “老旧版本支持”