分页: 1 / 1

求助,请问ubuntu12最高支持得libc6版本是多少?

发表于 : 2019-11-03 23:19
woshidabendan
公司有一台比较老的服务器,ubuntu12.几忘了,安装zabbix-agent提示要把libc6升级到2.17以上目前是2.15,请问可以升级上去吗,怕把系统搞瘫了

Re: 求助,请问ubuntu12最高支持得libc6版本是多少?

发表于 : 2019-11-04 9:40
astolia
不要单独升级glibc。12.04已经于2年前停止支持了,做服务器用的话最好还是整体升级到16.04或18.04。
如果实在不能升级,建议用虚拟化技术或容器技术来跑。比如docker的 https://hub.docker.com/r/zabbix/zabbix-agent/

Re: 求助,请问ubuntu12最高支持得libc6版本是多少?

发表于 : 2019-11-04 12:50
独行猫儿
astolia 写了:
2019-11-04 9:40
不要单独升级glibc。12.04已经于2年前停止支持了,做服务器用的话最好还是整体升级到16.04或18.04。
如果实在不能升级,建议用虚拟化技术或容器技术来跑。比如docker的 https://hub.docker.com/r/zabbix/zabbix-agent/
Docker同样不能在这种古董版本上运行。

老旧系统就不要干什么新鲜事,什么破公司破需求。

Re: 求助,请问ubuntu12最高支持得libc6版本是多少?

发表于 : 2019-11-04 14:25
astolia
独行猫儿 写了:
2019-11-04 12:50
Docker同样不能在这种古董版本上运行。
12.04最后一个hwe内核是3.13,怎么就不能运行docker了?

Re: 求助,请问ubuntu12最高支持得libc6版本是多少?

发表于 : 2019-11-05 10:13
独行猫儿
astolia 写了:
2019-11-04 14:25
独行猫儿 写了:
2019-11-04 12:50
Docker同样不能在这种古董版本上运行。
12.04最后一个hwe内核是3.13,怎么就不能运行docker了?
要用hwe么 :Hehe
理论上是没问题啦……理论上。