eclipse不能选tomcat6

软件和网站开发以及相关技术探讨
回复
老走刀口
帖子: 4
注册时间: 2014-05-03 21:20
系统: Ubuntu麒麟
送出感谢: 0
接收感谢: 0

eclipse不能选tomcat6

#1

帖子 老走刀口 » 2014-05-10 20:25

想在Ubuntu上搭建java WEB开发环境,JDK、Tomcat、Eclipse都已安装好了,在eclipse中创建了一个web项目,然后在新建Server的时候填不了Server Name,点击不了下一步,请问是什么原因啊,如何解决呢。
我用的Ubuntu版本是:Ubuntu麒麟14.04,JDK:是1.6,tomcat是6.0
[img]选区_001.png[/img]
附件
选区_001.png
老走刀口
帖子: 4
注册时间: 2014-05-03 21:20
系统: Ubuntu麒麟
送出感谢: 0
接收感谢: 0

Re: eclipse不能选tomcat6

#2

帖子 老走刀口 » 2014-05-10 22:02

没人知道吗?还是觉得太简单了,不屑回答。。。 :em20 :em20 :em20
老走刀口
帖子: 4
注册时间: 2014-05-03 21:20
系统: Ubuntu麒麟
送出感谢: 0
接收感谢: 0

Re: eclipse不能选tomcat6

#3

帖子 老走刀口 » 2014-05-10 22:18

补充:
我又发现一个现象,就是用root用户启动tomcat可以启动,目录:tomcat_home/bin,命令如下:
su
密码:×××××××
./startup.sh
但是已普通用户启动不了,命令如下:
sudo ./startup.sh
是否跟这个有关系。我觉得是eclipse没有访问tomcat的权限。就是不知道怎么解决,希望有人能告诉下啊
熊猫爱吃木瓜酸
帖子: 3
注册时间: 2014-06-14 8:32
系统: winxp
送出感谢: 0
接收感谢: 0

Re: eclipse不能选tomcat6

#4

帖子 熊猫爱吃木瓜酸 » 2014-07-12 9:06

你得装个tomcat的插件,就可以选。至于开启与关闭tomcat,你要给用户在tomcat文档的读写权限,你就可以在eclipse开启tomcat了!
回复

回到 “软件/网站开发”