PHP编译GD库支持报错

软件和网站开发以及相关技术探讨
回复
SuMic
帖子: 31
注册时间: 2007-08-30 1:25
送出感谢: 1 次
接收感谢: 0

PHP编译GD库支持报错

#1

帖子 SuMic » 2016-03-29 13:04

代码: 全选

Zend/zend_list.lo Zend/zend_indent.lo Zend/zend_builtin_functions.lo Zend/zend_sprintf.lo Zend/zend_ini.lo Zend/zend_qsort.lo Zend/zend_multibyte.lo Zend/zend_ts_hash.lo Zend/zend_stream.lo Zend/zend_iterators.lo Zend/zend_interfaces.lo Zend/zend_exceptions.lo Zend/zend_strtod.lo Zend/zend_gc.lo Zend/zend_closures.lo Zend/zend_float.lo Zend/zend_string.lo Zend/zend_signal.lo Zend/zend_objects.lo Zend/zend_object_handlers.lo Zend/zend_objects_API.lo Zend/zend_default_classes.lo Zend/zend_execute.lo sapi/apache2handler/mod_php5.lo sapi/apache2handler/sapi_apache2.lo sapi/apache2handler/apache_config.lo sapi/apache2handler/php_functions.lo main/internal_functions.lo -lcrypt -lz -lexslt -lresolv -lcrypt -ledit -ltermcap -lmcrypt -lltdl -lcurl -lbz2 -lz -lcrypto -lssl -lcrypto -lrt -lm -ldl -lnsl -lxml2 -lcurl -lxml2 -lxml2 -lcrypt -lxml2 -lxml2 -lxml2 -lxslt -lxml2 -lcrypt -o libphp5.4.45.la /bin/bash /home/sumic/.phpbrew/build/php-5.4.45/libtool --silent --preserve-dup-deps --mode=compile cc -I/usr/include -Iext/gd/ -I/home/sumic/.phpbrew/build/php-5.4.45/ext/gd/ -DPHP_ATOM_INC -I/home/sumic/.phpbrew/build/php-5.4.45/include -I/home/sumic/.phpbrew/build/php-5.4.45/main -I/home/sumic/.phpbrew/build/php-5.4.45 -I/home/sumic/.phpbrew/build/php-5.4.45/ext/date/lib -I/home/sumic/.phpbrew/build/php-5.4.45/ext/ereg/regex -I/usr/include/libxml2 -I/usr/local/include -I/usr/include/freetype2 -I/home/sumic/.phpbrew/build/php-5.4.45/ext/mbstring/oniguruma -I/home/sumic/.phpbrew/build/php-5.4.45/ext/mbstring/libmbfl -I/home/sumic/.phpbrew/build/php-5.4.45/ext/mbstring/libmbfl/mbfl -I/home/sumic/.phpbrew/build/php-5.4.45/TSRM -I/home/sumic/.phpbrew/build/php-5.4.45/Zend -g -O2 -fvisibility=hidden -c /home/sumic/.phpbrew/build/php-5.4.45/ext/gd/gd.c -o ext/gd/gd.lo /bin/bash /home/sumic/.phpbrew/build/php-5.4.45/libtool --silent --preserve-dup-deps --mode=compile cc -I/usr/include -Iext/gd/ -I/home/sumic/.phpbrew/build/php-5.4.45/ext/gd/ -DPHP_ATOM_INC -I/home/sumic/.phpbrew/build/php-5.4.45/include -I/home/sumic/.phpbrew/build/php-5.4.45/main -I/home/sumic/.phpbrew/build/php-5.4.45 -I/home/sumic/.phpbrew/build/php-5.4.45/ext/date/lib -I/home/sumic/.phpbrew/build/php-5.4.45/ext/ereg/regex -I/usr/include/libxml2 -I/usr/local/include -I/usr/include/freetype2 -I/home/sumic/.phpbrew/build/php-5.4.45/ext/mbstring/oniguruma -I/home/sumic/.phpbrew/build/php-5.4.45/ext/mbstring/libmbfl -I/home/sumic/.phpbrew/build/php-5.4.45/ext/mbstring/libmbfl/mbfl -I/home/sumic/.phpbrew/build/php-5.4.45/TSRM -I/home/sumic/.phpbrew/build/php-5.4.45/Zend -g -O2 -fvisibility=hidden -c /home/sumic/.phpbrew/build/php-5.4.45/ext/gd/gdcache.c -o ext/gd/gdcache.lo /bin/bash /home/sumic/.phpbrew/build/php-5.4.45/libtool --silent --preserve-dup-deps --mode=compile cc -I/usr/include -Iext/gd/ -I/home/sumic/.phpbrew/build/php-5.4.45/ext/gd/ -DPHP_ATOM_INC -I/home/sumic/.phpbrew/build/php-5.4.45/include -I/home/sumic/.phpbrew/build/php-5.4.45/main -I/home/sumic/.phpbrew/build/php-5.4.45 -I/home/sumic/.phpbrew/build/php-5.4.45/ext/date/lib -I/home/sumic/.phpbrew/build/php-5.4.45/ext/ereg/regex -I/usr/include/libxml2 -I/usr/local/include -I/usr/include/freetype2 -I/home/sumic/.phpbrew/build/php-5.4.45/ext/mbstring/oniguruma -I/home/sumic/.phpbrew/build/php-5.4.45/ext/mbstring/libmbfl -I/home/sumic/.phpbrew/build/php-5.4.45/ext/mbstring/libmbfl/mbfl -I/home/sumic/.phpbrew/build/php-5.4.45/TSRM -I/home/sumic/.phpbrew/build/php-5.4.45/Zend -g -O2 -fvisibility=hidden -c /home/sumic/.phpbrew/build/php-5.4.45/ext/gd/libgd/gd_compat.c -o ext/gd/libgd/gd_compat.lo /home/sumic/.phpbrew/build/php-5.4.45/ext/gd/libgd/gd_compat.c: In function ‘gdJpegGetVersionInt’: /home/sumic/.phpbrew/build/php-5.4.45/ext/gd/libgd/gd_compat.c:14:9: error: ‘JPEG_LIB_VERSION’ undeclared (first use in this function) return JPEG_LIB_VERSION; ^ /home/sumic/.phpbrew/build/php-5.4.45/ext/gd/libgd/gd_compat.c:14:9: note: each undeclared identifier is reported only once for each function it appears in /home/sumic/.phpbrew/build/php-5.4.45/ext/gd/libgd/gd_compat.c: In function ‘gdJpegGetVersionString’: /home/sumic/.phpbrew/build/php-5.4.45/ext/gd/libgd/gd_compat.c:19:9: error: ‘JPEG_LIB_VERSION’ undeclared (first use in this function) switch(JPEG_LIB_VERSION) { ^ make: *** [ext/gd/libgd/gd_compat.lo] Error 1Zend/zend_list.lo Zend/zend_indent.lo Zend/zend_builtin_functions.lo Zend/zend_sprintf.lo Zend/zend_ini.lo Zend/zend_qsort.lo Zend/zend_multibyte.lo Zend/zend_ts_hash.lo Zend/zend_stream.lo Zend/zend_iterators.lo Zend/zend_interfaces.lo Zend/zend_exceptions.lo Zend/zend_strtod.lo Zend/zend_gc.lo Zend/zend_closures.lo Zend/zend_float.lo Zend/zend_string.lo Zend/zend_signal.lo Zend/zend_objects.lo Zend/zend_object_handlers.lo Zend/zend_objects_API.lo Zend/zend_default_classes.lo Zend/zend_execute.lo sapi/apache2handler/mod_php5.lo sapi/apache2handler/sapi_apache2.lo sapi/apache2handler/apache_config.lo sapi/apache2handler/php_functions.lo main/internal_functions.lo -lcrypt -lz -lexslt -lresolv -lcrypt -ledit -ltermcap -lmcrypt -lltdl -lcurl -lbz2 -lz -lcrypto -lssl -lcrypto -lrt -lm -ldl -lnsl -lxml2 -lcurl -lxml2 -lxml2 -lcrypt -lxml2 -lxml2 -lxml2 -lxslt -lxml2 -lcrypt -o libphp5.4.45.la /bin/bash /home/sumic/.phpbrew/build/php-5.4.45/libtool --silent --preserve-dup-deps --mode=compile cc -I/usr/include -Iext/gd/ -I/home/sumic/.phpbrew/build/php-5.4.45/ext/gd/ -DPHP_ATOM_INC -I/home/sumic/.phpbrew/build/php-5.4.45/include -I/home/sumic/.phpbrew/build/php-5.4.45/main -I/home/sumic/.phpbrew/build/php-5.4.45 -I/home/sumic/.phpbrew/build/php-5.4.45/ext/date/lib -I/home/sumic/.phpbrew/build/php-5.4.45/ext/ereg/regex -I/usr/include/libxml2 -I/usr/local/include -I/usr/include/freetype2 -I/home/sumic/.phpbrew/build/php-5.4.45/ext/mbstring/oniguruma -I/home/sumic/.phpbrew/build/php-5.4.45/ext/mbstring/libmbfl -I/home/sumic/.phpbrew/build/php-5.4.45/ext/mbstring/libmbfl/mbfl -I/home/sumic/.phpbrew/build/php-5.4.45/TSRM -I/home/sumic/.phpbrew/build/php-5.4.45/Zend -g -O2 -fvisibility=hidden -c /home/sumic/.phpbrew/build/php-5.4.45/ext/gd/gd.c -o ext/gd/gd.lo /bin/bash /home/sumic/.phpbrew/build/php-5.4.45/libtool --silent --preserve-dup-deps --mode=compile cc -I/usr/include -Iext/gd/ -I/home/sumic/.phpbrew/build/php-5.4.45/ext/gd/ -DPHP_ATOM_INC -I/home/sumic/.phpbrew/build/php-5.4.45/include -I/home/sumic/.phpbrew/build/php-5.4.45/main -I/home/sumic/.phpbrew/build/php-5.4.45 -I/home/sumic/.phpbrew/build/php-5.4.45/ext/date/lib -I/home/sumic/.phpbrew/build/php-5.4.45/ext/ereg/regex -I/usr/include/libxml2 -I/usr/local/include -I/usr/include/freetype2 -I/home/sumic/.phpbrew/build/php-5.4.45/ext/mbstring/oniguruma -I/home/sumic/.phpbrew/build/php-5.4.45/ext/mbstring/libmbfl -I/home/sumic/.phpbrew/build/php-5.4.45/ext/mbstring/libmbfl/mbfl -I/home/sumic/.phpbrew/build/php-5.4.45/TSRM -I/home/sumic/.phpbrew/build/php-5.4.45/Zend -g -O2 -fvisibility=hidden -c /home/sumic/.phpbrew/build/php-5.4.45/ext/gd/gdcache.c -o ext/gd/gdcache.lo /bin/bash /home/sumic/.phpbrew/build/php-5.4.45/libtool --silent --preserve-dup-deps --mode=compile cc -I/usr/include -Iext/gd/ -I/home/sumic/.phpbrew/build/php-5.4.45/ext/gd/ -DPHP_ATOM_INC -I/home/sumic/.phpbrew/build/php-5.4.45/include -I/home/sumic/.phpbrew/build/php-5.4.45/main -I/home/sumic/.phpbrew/build/php-5.4.45 -I/home/sumic/.phpbrew/build/php-5.4.45/ext/date/lib -I/home/sumic/.phpbrew/build/php-5.4.45/ext/ereg/regex -I/usr/include/libxml2 -I/usr/local/include -I/usr/include/freetype2 -I/home/sumic/.phpbrew/build/php-5.4.45/ext/mbstring/oniguruma -I/home/sumic/.phpbrew/build/php-5.4.45/ext/mbstring/libmbfl -I/home/sumic/.phpbrew/build/php-5.4.45/ext/mbstring/libmbfl/mbfl -I/home/sumic/.phpbrew/build/php-5.4.45/TSRM -I/home/sumic/.phpbrew/build/php-5.4.45/Zend -g -O2 -fvisibility=hidden -c /home/sumic/.phpbrew/build/php-5.4.45/ext/gd/libgd/gd_compat.c -o ext/gd/libgd/gd_compat.lo /home/sumic/.phpbrew/build/php-5.4.45/ext/gd/libgd/gd_compat.c: In function ‘gdJpegGetVersionInt’: /home/sumic/.phpbrew/build/php-5.4.45/ext/gd/libgd/gd_compat.c:14:9: error: ‘JPEG_LIB_VERSION’ undeclared (first use in this function) return JPEG_LIB_VERSION; ^ /home/sumic/.phpbrew/build/php-5.4.45/ext/gd/libgd/gd_compat.c:14:9: note: each undeclared identifier is reported only once for each function it appears in /home/sumic/.phpbrew/build/php-5.4.45/ext/gd/libgd/gd_compat.c: In function ‘gdJpegGetVersionString’: /home/sumic/.phpbrew/build/php-5.4.45/ext/gd/libgd/gd_compat.c:19:9: error: ‘JPEG_LIB_VERSION’ undeclared (first use in this function) switch(JPEG_LIB_VERSION) { ^ make: *** [ext/gd/libgd/gd_compat.lo] Error 1
大神帮看看什么问题,各种lib库都已经安装好了,折腾了一天了
科学之子
帖子: 2281
注册时间: 2013-05-26 6:58
系统: Debian 9
送出感谢: 849 次
接收感谢: 32 次

Re: PHP编译GD库支持报错

#2

帖子 科学之子 » 2016-03-29 15:35

里面各种"undeclared"错误

可能是还是缺少头文件

代码: 全选

~# apt-file search jpeglib.h
icedove-dev: /usr/include/icedove/jpeglib.h
iceweasel-dev: /usr/include/iceweasel-38/jpeglib.h
libgdcm2-dev: /usr/include/gdcm-2.4/gdcmjpeg/12/jpeglib.h
libgdcm2-dev: /usr/include/gdcm-2.4/gdcmjpeg/16/jpeglib.h
libgdcm2-dev: /usr/include/gdcm-2.4/gdcmjpeg/8/jpeglib.h
libgdcm2-dev: /usr/include/gdcm-2.4/gdcmjpeg/jpeglib.h
libjpeg62-turbo-dev: /usr/include/jpeglib.h
libvxl1-dev: /usr/include/vxl/core/vil/file_formats/vil_jpeglib.h
libvxl1-dev: /usr/include/vxl/core/vil1/vil1_jpeglib.h
搜索的头文件名称是通过谷歌搜索"JPEG_LIB_VERSION undeclared "得到的
https://www.google.com/?gws_rd=ssl#q=JP ... undeclared+
再不行就只能人工把那个报错的源文件人工展开,每个头文件都用这种方式搜一遍.
或者有什么方法能直接搜索deb包的文本内容?
回复

回到 “软件/网站开发”