phpmyadmin 安装报错 大神指点下

软件和网站开发以及相关技术探讨
回复
SuMic
帖子: 31
注册时间: 2007-08-30 1:25
送出感谢: 1 次
接收感谢: 0

phpmyadmin 安装报错 大神指点下

#1

帖子 SuMic » 2016-04-12 12:27

我是直接 sudo apt-get install phpmyadmin的

代码: 全选

Reading package lists... Done
Building dependency tree       
Reading state information... Done
phpmyadmin is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 11 not upgraded.
1 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n] y
Setting up phpmyadmin (4:4.0.10-1) ...
dbconfig-common: writing config to /etc/dbconfig-common/phpmyadmin.conf
Replacing config file /etc/phpmyadmin/config-db.php with new version
dbconfig-common: flushing administrative password
dpkg: error processing package phpmyadmin (--configure):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 phpmyadmin
E: Sub-process /usr/bin/dpkg returned an error code (1)

帮忙看看啥问题,也没看到什么错误提示
wit
帖子: 11
注册时间: 2016-10-01 9:59
系统: ubuntu
送出感谢: 0
接收感谢: 0

Re: phpmyadmin 安装报错 大神指点下

#2

帖子 wit » 2016-11-01 18:35

dpkg: 处理软件包 xxxxxx (--configure)时出错:
子进程 已安装 post-installation 脚本 返回错误状态 1
dpkg: 依赖关系问题使得 ttf-mscorefonts-installer 的配置工作不能继续:
解决方法

1.$ sudo mv /var/lib/dpkg/info /var/lib/dpkg/info_old //现将info文件夹更名
2.$ sudo mkdir /var/lib/dpkg/info //再新建一个新的info文件夹
3.$ sudo apt-get update
4.$ apt-get -f install
5.$ sudo mv /var/lib/dpkg/info/* /var/lib/dpkg/info_old //执行完上一步操作后会在新的info文件夹下生成一些文件,现将这些文件全部移到info_old文件夹下
6.$ sudo rm -rf /var/lib/dpkg/info //把自己新建的info文件夹删掉
7.$ sudo mv /var/lib/dpkg/info_old /var/lib/dpkg/info //把以前的info文件夹重新改回名字

8.$$ sudo rm /var/crash/* //删除错误报告文件

//////////////////////////////////
头像
TeliuTe
论坛版主
帖子: 7599
注册时间: 2007-11-25 13:29
系统: 14/16/18/Fedroa22/w7
来自: 新疆博乐
送出感谢: 30 次
接收感谢: 106 次
联系:

Re: phpmyadmin 安装报错 大神指点下

#3

帖子 TeliuTe » 2016-11-01 22:29

看提示已经是最新版,像是配置文件出错,查看一下 /etc/phpmyadmin 里的文件,
或者先完全卸载(purge)后重新安装
回复

回到 “软件/网站开发”