cmake-gui的启动问题

软件和网站开发以及相关技术探讨
回复
头像
sh42
帖子: 101
注册时间: 2011-05-01 20:18
送出感谢: 3 次
接收感谢: 0

cmake-gui的启动问题

#1

帖子 sh42 » 2016-06-02 14:27

问题很简单,我安装完了之后启动出现这个问题,跪求怎么解决:


[email protected]:/etc/lightdm$ cmake-gui
This application failed to start because it could not find or load the Qt platform plugin "xcb".

Available platform plugins are: linuxfb, minimal, minimalegl, offscreen.

Reinstalling the application may fix this problem.
Aborted (core dumped)
头像
vickycq
帖子: 4507
注册时间: 2011-03-20 13:12
系统: Debian
来自: 山东省寿光县
送出感谢: 100 次
接收感谢: 991 次
联系:

Re: cmake-gui的启动问题

#2

帖子 vickycq » 2016-06-02 16:00

1. 检查 libqt5gui5 是否正确安装
3. find /usr/lib | grep libqxcb.so | xargs ldd 看有没有缺损
2. 是否安装过乱七八糟的第三方应用,搞乱了相关配置。例如 115pan 客户端
4. 实在找不出原因只好暂时指定 QT_QPA_PLATFORM_PLUGIN_PATH 启动应用程序。例如 QT_QPA_PLATFORM_PLUGIN_PATH=/usr/lib/x86_64-linux-gnu/qt5/plugins/ cmake-gui
Debian 中文论坛 - forums.debiancn.org
欢迎所有 Debian GNU/Linux 用户
头像
sh42
帖子: 101
注册时间: 2011-05-01 20:18
送出感谢: 3 次
接收感谢: 0

Re: cmake-gui的启动问题

#3

帖子 sh42 » 2016-06-03 10:33

vickycq 写了:1. 检查 libqt5gui5 是否正确安装
3. find /usr/lib | grep libqxcb.so | xargs ldd 看有没有缺损
2. 是否安装过乱七八糟的第三方应用,搞乱了相关配置。例如 115pan 客户端
4. 实在找不出原因只好暂时指定 QT_QPA_PLATFORM_PLUGIN_PATH 启动应用程序。例如 QT_QPA_PLATFORM_PLUGIN_PATH=/usr/lib/x86_64-linux-gnu/qt5/plugins/ cmake-gui

正解!我把所有和qt有关的应用包全部卸载,再安装就可以了。
回复

回到 “软件/网站开发”