希望ubuntu.org.cn制作PHP5的升级源

软件和网站开发以及相关技术探讨
回复
bighan
帖子: 28
注册时间: 2005-05-11 12:08
送出感谢: 0
接收感谢: 0

希望ubuntu.org.cn制作PHP5的升级源

#1

帖子 bighan » 2005-05-25 5:22

PHP5出来这么时间了,也该升级了。
头像
oneleaf
论坛管理员
帖子: 10357
注册时间: 2005-03-27 0:06
系统: Ubuntu 12.04
送出感谢: 7 次
接收感谢: 114 次

#2

帖子 oneleaf » 2005-05-25 8:41

/etc/apt/sources.list:
# PHP5
deb http://people.debian.org/~dexter php5 sid
deb-src http://people.debian.org/~dexter php5 sid

我没有做测试,你可以试试。
当净其意如虚空,远离妄想及诸取,令心所向皆无碍
头像
oneleaf
论坛管理员
帖子: 10357
注册时间: 2005-03-27 0:06
系统: Ubuntu 12.04
送出感谢: 7 次
接收感谢: 114 次

#3

帖子 oneleaf » 2005-05-25 8:41

#PHP5
deb http://packages.dotdeb.org ./

这个源也可以
当净其意如虚空,远离妄想及诸取,令心所向皆无碍
bighan
帖子: 28
注册时间: 2005-05-11 12:08
送出感谢: 0
接收感谢: 0

#4

帖子 bighan » 2005-05-30 22:05

谢谢,少一个库文件老装不上,还是自己试试编译一下吧。
头像
jerysun
帖子: 36
注册时间: 2005-07-13 20:25
来自: 山东
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 jerysun » 2005-07-13 20:28

自己编译吧。
不过如果是apt安装的apache or apache2,找不到apxs呢,哪位大侠告诉一声?
Ubuntu 8.04
Sempron 2800+/256M×2/80GSATA/MX400
头像
oneleaf
论坛管理员
帖子: 10357
注册时间: 2005-03-27 0:06
系统: Ubuntu 12.04
送出感谢: 7 次
接收感谢: 114 次

#6

帖子 oneleaf » 2005-07-13 21:33

源加了,试试?
当净其意如虚空,远离妄想及诸取,令心所向皆无碍
头像
jerysun
帖子: 36
注册时间: 2005-07-13 20:25
来自: 山东
送出感谢: 0
接收感谢: 0
联系:

确实是提示缺少库文件

#7

帖子 jerysun » 2005-07-14 0:56

php5: 依赖: libmm11 但却无法安装它
一个网友解决了,但没看明白是怎么弄的。
http://www.linuxquestions.org/questions/history/334047
Ubuntu 8.04
Sempron 2800+/256M×2/80GSATA/MX400
yongyi
帖子: 3025
注册时间: 2005-05-07 23:57
送出感谢: 0
接收感谢: 0
联系:

#8

帖子 yongyi » 2005-07-14 8:42

看楼上的地址里的人并没有解决,他好像是放弃PHP5,而装上的是PHP4。

今天在breezy 源中搜索一下,发现已经有PHP5的了。
不过,如果你现在用着hoary的话,请三思,最好不要尝试用breezy的源来安装。除非你对它的依赖非常清楚。不然,很容易一步步地被迫着向上升级。

对了,如果要装PHP5,什么命令能最好地卸载PHP4呢?
我直接安装PHP5,发现并不会自动把PHP4升级或卸载掉。
独自看一看大海
总想起身边走在路上的朋友
Lenovo E290-420[Celeron-M420/256M/60G/Intel GMA950]
头像
firehare
帖子: 2625
注册时间: 2005-04-10 16:54
来自: 温州大学
送出感谢: 0
接收感谢: 2 次
联系:

#9

帖子 firehare » 2005-07-14 12:30

一叶兄已经提供了PHP5的包,是For 5.04的!大家可以不再困扰了!
我心无畏,源自于我心无知。
图片
头像
jerysun
帖子: 36
注册时间: 2005-07-13 20:25
来自: 山东
送出感谢: 0
接收感谢: 0
联系:

#10

帖子 jerysun » 2005-07-14 12:44

firehare 写了:一叶兄已经提供了PHP5的包,是For 5.04的!大家可以不再困扰了!
sure?
在哪里?
Ubuntu 8.04
Sempron 2800+/256M×2/80GSATA/MX400
yongyi
帖子: 3025
注册时间: 2005-05-07 23:57
送出感谢: 0
接收感谢: 0
联系:

#11

帖子 yongyi » 2005-07-14 12:51

独自看一看大海
总想起身边走在路上的朋友
Lenovo E290-420[Celeron-M420/256M/60G/Intel GMA950]
回复

回到 “软件/网站开发”