让aMule支持DLP的源码补丁(1月24日更新了~)

上网、浏览、聊天、下载等
回复
头像
john.wu
帖子: 1006
注册时间: 2007-10-18 17:40
送出感谢: 0
接收感谢: 0

Re: 让aMule支持DLP的源码补丁(更新至3903)

#61

帖子 john.wu » 2009-10-31 20:57

Bill Lee 写了:我之前还一直纳闷呢,eMule Xtreme Mod和aMule都是开源的,怎么就没人把DLP移植过来
不过毕竟还是有高手想到这个问题的。
建议楼主做个deb包吧,毕竟,不是大家都会编译的
详情见这里

viewtopic.php?f=95&t=233117

千帖户,享有论坛特权!
头像
midoriumi
帖子: 40
注册时间: 2009-02-24 13:07
送出感谢: 0
接收感谢: 0
联系:

Re: 让aMule支持DLP的源码补丁(更新至3903)

#62

帖子 midoriumi » 2009-11-01 10:54

食古不化 写了:是否能考虑把补丁提供给官方呢?
官方开发人员曾经说过,DLP占用资源、不能完全屏蔽吸血驴而且存在误杀,所以不打算给aMule加上DLP。

另外这个补丁也还不完善,目前不能自定义屏蔽规则。最近在学校忙着弄专业实习的材料,就业推荐表的材料以及其他乱七八糟的麻烦事,没时间继续做下去,看样子也许只有寒假能有一些时间了。

顺便怨念一下,编译原理竟然被放到这个学期来上,而且还不是必修课,这算什么计算机本科专业啊。嗯……学了编译原理以后说不定可以弄个简单的编译器把DLP的C语言代码转到那个cam什么的代码去,这样就可以很方便地开发mldonkey用的DLP了
叫我greensea吧 [@lvhai]

虽然现在这个用户名是midoriumi,但实际上是我把自己注册的greensea的密码给忘记了,于是只好再注册一个midoriumi,字面意思也和greensea一样是緑海(みどりうみ)。所以,叫我greensea或GS吧。
Bill Lee
帖子: 598
注册时间: 2009-09-19 20:50
送出感谢: 0
接收感谢: 2 次

Re: 让aMule支持DLP的源码补丁(更新至3903)

#63

帖子 Bill Lee » 2009-11-01 20:28

执行./configure的时候出了错
提示
error:
...
...no wxWigdets GUI ...
...
什么的
原来还要依赖libwxgtk-2.8-dev这个包,另外./configure时upnp不是必要的,对于ADSL用户来说,UPnP似乎没什么用吧。根据自己的实际情况,可以把--enable-upnp改成--disable-upnp
aMule 2.3.1 is coming...
真正动态的 amule-dlp is coming...
本人帐号在2011年1月被盗,在2011年1月3日17:19到2010年1月6日13:34之间本帐号发的一切帖子、短信等与本人无关!
amule-dlp 开发动态
amule-dlp on Google Code
WebArchiver - 基于 wget 的网页归档工具(PyQt4 GUI 前端)
Linux 2.6.34 编译笔记
Bill Lee
帖子: 598
注册时间: 2009-09-19 20:50
送出感谢: 0
接收感谢: 2 次

Re: 让aMule支持DLP的源码补丁(更新至3903)

#64

帖子 Bill Lee » 2009-11-01 20:32

midoriumi 写了:
食古不化 写了:是否能考虑把补丁提供给官方呢?
官方开发人员曾经说过,DLP占用资源、不能完全屏蔽吸血驴而且存在误杀,所以不打算给aMule加上DLP。

另外这个补丁也还不完善,目前不能自定义屏蔽规则。最近在学校忙着弄专业实习的材料,就业推荐表的材料以及其他乱七八糟的麻烦事,没时间继续做下去,看样子也许只有寒假能有一些时间了。

顺便怨念一下,编译原理竟然被放到这个学期来上,而且还不是必修课,这算什么计算机本科专业啊。嗯……学了编译原理以后说不定可以弄个简单的编译器把DLP的C语言代码转到那个cam什么的代码去,这样就可以很方便地开发mldonkey用的DLP了
其实就自己用来说,自定义屏蔽规则实际是没什么用的,我从来都是全部ban。
不过如果不能设置看起来又好像做工不良的软件,aMule不加就由他去吧,eMule也没家呀,以后大家就可以用一个叫做midoriumi Mod的aMule了
aMule 2.3.1 is coming...
真正动态的 amule-dlp is coming...
本人帐号在2011年1月被盗,在2011年1月3日17:19到2010年1月6日13:34之间本帐号发的一切帖子、短信等与本人无关!
amule-dlp 开发动态
amule-dlp on Google Code
WebArchiver - 基于 wget 的网页归档工具(PyQt4 GUI 前端)
Linux 2.6.34 编译笔记
头像
行远自迩
帖子: 403
注册时间: 2009-04-19 15:27
送出感谢: 4 次
接收感谢: 0

Re: 让aMule支持DLP的源码补丁(更新至3903)

#65

帖子 行远自迩 » 2009-11-04 13:21

哈哈,和原版的一样好用,速度不慢,更重要的是能防被吸血了。

:em38
附件
Screenshot.png
Screenshot.png
无从完美。
头像
iwanderer
帖子: 103
注册时间: 2009-01-15 20:19
送出感谢: 0
接收感谢: 0

Re: 让aMule支持DLP的源码补丁(更新至3903)

#66

帖子 iwanderer » 2009-11-04 21:41

mark ,有空仔细弄弄
Bill Lee
帖子: 598
注册时间: 2009-09-19 20:50
送出感谢: 0
接收感谢: 2 次

Re: 让aMule支持DLP的源码补丁(更新至3903)

#67

帖子 Bill Lee » 2009-11-06 17:51

真的很好用,稳定
看着Log里的一堆Xunlei真是大快人心
aMule 2.3.1 is coming...
真正动态的 amule-dlp is coming...
本人帐号在2011年1月被盗,在2011年1月3日17:19到2010年1月6日13:34之间本帐号发的一切帖子、短信等与本人无关!
amule-dlp 开发动态
amule-dlp on Google Code
WebArchiver - 基于 wget 的网页归档工具(PyQt4 GUI 前端)
Linux 2.6.34 编译笔记
头像
daf3707
论坛版主
帖子: 12679
注册时间: 2007-06-13 15:57
来自: 在他乡
送出感谢: 49 次
接收感谢: 85 次

Re: 让aMule支持DLP的源码补丁(更新至3903)

#68

帖子 daf3707 » 2009-11-07 10:45

与火狐关联不上啊?
Bill Lee
帖子: 598
注册时间: 2009-09-19 20:50
送出感谢: 0
接收感谢: 2 次

Re: 让aMule支持DLP的源码补丁(更新至3903)

#69

帖子 Bill Lee » 2009-11-07 21:20

daf3707 写了:与火狐关联不上啊?
自己把ED2K链接贴到aMule的输入框里
aMule 2.3.1 is coming...
真正动态的 amule-dlp is coming...
本人帐号在2011年1月被盗,在2011年1月3日17:19到2010年1月6日13:34之间本帐号发的一切帖子、短信等与本人无关!
amule-dlp 开发动态
amule-dlp on Google Code
WebArchiver - 基于 wget 的网页归档工具(PyQt4 GUI 前端)
Linux 2.6.34 编译笔记
pbus
帖子: 26
注册时间: 2008-09-12 14:00
送出感谢: 0
接收感谢: 0

Re: 让aMule支持DLP的源码补丁(更新至3903)

#70

帖子 pbus » 2009-11-10 10:38

按lz的方法搞定了
界面确实多了一个动态反吸血
感谢lz :em11
没有草木为剑的本领,却可以有草木为剑的胸襟!
头像
Whistler
帖子: 157
注册时间: 2006-09-05 11:01
送出感谢: 0
接收感谢: 1 次
联系:

Re: 让aMule支持DLP的源码补丁(更新至3903)

#71

帖子 Whistler » 2009-11-17 13:41

对 hello tag 不检测还是漏了一部份吸血雷的 :em20
不过不错 :em09
头像
Whistler
帖子: 157
注册时间: 2006-09-05 11:01
送出感谢: 0
接收感谢: 1 次
联系:

Re: 让aMule支持DLP的源码补丁(更新至3903)

#72

帖子 Whistler » 2009-11-17 16:32

还有 modstring 是 20080409 的也是吸血雷,但现在这个版本没有检测。
beyondlion
帖子: 190
注册时间: 2008-11-13 7:59
送出感谢: 0
接收感谢: 0

Re: 让aMule支持DLP的源码补丁(更新至3903)

#73

帖子 beyondlion » 2009-11-17 21:52

看不懂 :em20
头像
foolegg
帖子: 249
注册时间: 2007-12-01 14:56
送出感谢: 0
接收感谢: 0

Re: 让aMule支持DLP的源码补丁(更新至3903)

#74

帖子 foolegg » 2009-11-21 12:22

几秒后崩溃

configure

代码: 全选

./configure --disable-debug --enable-optimize --enable-upnp --enable-geoip --enable-nls --enable-alcc -disable-alc --enable-cas --disable-wxcas --enable-mmap --disable-amule-gui --enable-amule-daemon --disable-monolithic
出错信息

代码: 全选

Current version is: aMuled 2.2.6 using wxGTK2 v2.8.7
Running on: Linux 2.6.24-25-server i686

[2] ?? in ./amuled [0x80724c1]
[3] wxFatalSignalHandler in /usr/lib/libwx_baseu-2.8.so.0[0xb7a701d6]
[4] ?? in [0xb7f8f420]
[5] GSocket::Input_Timeout() in /usr/lib/libwx_baseu_net-2.8.so.0[0xb7affef7]
[6] GSocket::Read(char*, int) in /usr/lib/libwx_baseu_net-2.8.so.0[0xb7afffc8]
[7] wxSocketBase::_Read(void*, unsigned int) in /usr/lib/libwx_baseu_net-2.8.so.0[0xb7afb481]
[8] wxSocketBase::Peek(void*, unsigned int) in /usr/lib/libwx_baseu_net-2.8.so.0[0xb7afb5c7]
[9] wxProtocol::ReadLine(wxSocketBase*, wxString&) in /usr/lib/libwx_baseu_net-2.8.so.0[0xb7af4e2f]
[10] wxHTTP::ParseHeaders() in /usr/lib/libwx_baseu_net-2.8.so.0[0xb7af2242]
[11] wxHTTP::BuildRequest(wxString const&, wxHTTP::wxHTTP_Req) in /usr/lib/libwx_baseu_net-2.8.so.0[0xb7af38f3]
[12] wxHTTP::GetInputStream(wxString const&) in /usr/lib/libwx_baseu_net-2.8.so.0[0xb7af3d36]
[13] ?? in ./amuled [0x80e5e84]
[14] ?? in ./amuled [0x80e658e]
[15] wxThreadInternal::PthreadStart(wxThread*) in /usr/lib/libwx_baseu-2.8.so.0[0xb7a6a4b8]
[16] wxPthreadStart in /usr/lib/libwx_baseu-2.8.so.0[0xb7a6a52d]
[17] ?? in /lib/tls/i686/cmov/libpthread.so.0 [0xb7f734fb]
[18] clone in /lib/tls/i686/cmov/libc.so.6[0xb77e2e5e]
头像
midoriumi
帖子: 40
注册时间: 2009-02-24 13:07
送出感谢: 0
接收感谢: 0
联系:

Re: 让aMule支持DLP的源码补丁(更新至3903)

#75

帖子 midoriumi » 2009-11-21 13:32

foolegg 写了:几秒后崩溃
如果方便的话,还请你使用 --enable-debug 参数configure后再运行,这样能给出更加详尽的错误信息,方便我定位错误。
叫我greensea吧 [@lvhai]

虽然现在这个用户名是midoriumi,但实际上是我把自己注册的greensea的密码给忘记了,于是只好再注册一个midoriumi,字面意思也和greensea一样是緑海(みどりうみ)。所以,叫我greensea或GS吧。
回复

回到 “因特网相关软件”