软件中心报错

为当前最终发行版之前的所有版本提供支持
回复
parkkimlin
帖子: 3
注册时间: 2012-12-22 10:31
系统: ubuntu
送出感谢: 0
接收感谢: 0

软件中心报错

#1

帖子 parkkimlin » 2015-04-13 11:29

请大侠帮忙解答下,运行软件中心就会报这种错误,python已经更新了还是不行
dejya@dejya:/usr/bin$ software-center
Traceback (most recent call last):
File "/usr/bin/software-center", line 36, in <module>
from softwarecenter.utils import (
File "/usr/share/software-center/softwarecenter/utils.py", line 19, in <module>
import dbus
File "/usr/lib/python2.7/dist-packages/dbus/__init__.py", line 103, in <module>
from dbus._dbus import Bus, SystemBus, SessionBus, StarterBus
File "/usr/lib/python2.7/dist-packages/dbus/_dbus.py", line 39, in <module>
from dbus.bus import BusConnection
File "/usr/lib/python2.7/dist-packages/dbus/bus.py", line 39, in <module>
from dbus.connection import Connection
File "/usr/lib/python2.7/dist-packages/dbus/connection.py", line 37, in <module>
from dbus.proxies import ProxyObject
File "/usr/lib/python2.7/dist-packages/dbus/proxies.py", line 34, in <module>
from dbus._expat_introspect_parser import process_introspection_data
File "/usr/lib/python2.7/dist-packages/dbus/_expat_introspect_parser.py", line 26, in <module>
from xml.parsers.expat import ParserCreate
File "/usr/lib/python2.7/xml/parsers/expat.py", line 4, in <module>
from pyexpat import *
ImportError: /usr/lib/python2.7/lib-dynload/pyexpat.x86_64-linux-gnu.so: undefined symbol: XML_SetHashSalt
头像
jackness
帖子: 343
注册时间: 2010-08-02 8:19
系统: windows7旗舰版 ubuntu
送出感谢: 10 次
接收感谢: 1 次

Re: 软件中心报错

#2

帖子 jackness » 2015-04-13 11:40

parkkimlin 写了:请大侠帮忙解答下,运行软件中心就会报这种错误,python已经更新了还是不行
dejya@dejya:/usr/bin$ software-center
Traceback (most recent call last):
File "/usr/bin/software-center", line 36, in <module>
from softwarecenter.utils import (
File "/usr/share/software-center/softwarecenter/utils.py", line 19, in <module>
import dbus
File "/usr/lib/python2.7/dist-packages/dbus/__init__.py", line 103, in <module>
from dbus._dbus import Bus, SystemBus, SessionBus, StarterBus
File "/usr/lib/python2.7/dist-packages/dbus/_dbus.py", line 39, in <module>
from dbus.bus import BusConnection
File "/usr/lib/python2.7/dist-packages/dbus/bus.py", line 39, in <module>
from dbus.connection import Connection
File "/usr/lib/python2.7/dist-packages/dbus/connection.py", line 37, in <module>
from dbus.proxies import ProxyObject
File "/usr/lib/python2.7/dist-packages/dbus/proxies.py", line 34, in <module>
from dbus._expat_introspect_parser import process_introspection_data
File "/usr/lib/python2.7/dist-packages/dbus/_expat_introspect_parser.py", line 26, in <module>
from xml.parsers.expat import ParserCreate
File "/usr/lib/python2.7/xml/parsers/expat.py", line 4, in <module>
from pyexpat import *
ImportError: /usr/lib/python2.7/lib-dynload/pyexpat.x86_64-linux-gnu.so: undefined symbol: XML_SetHashSalt
你为什么用终端打开呢?不是有GUI么?你的网络是不是有问题啊?希望大神们搭救你,谢谢发帖。祝你生活愉快!
parkkimlin
帖子: 3
注册时间: 2012-12-22 10:31
系统: ubuntu
送出感谢: 0
接收感谢: 0

Re: 软件中心报错

#3

帖子 parkkimlin » 2015-04-13 11:42

jackness 写了:
parkkimlin 写了:请大侠帮忙解答下,运行软件中心就会报这种错误,python已经更新了还是不行
dejya@dejya:/usr/bin$ software-center
Traceback (most recent call last):
File "/usr/bin/software-center", line 36, in <module>
from softwarecenter.utils import (
File "/usr/share/software-center/softwarecenter/utils.py", line 19, in <module>
import dbus
File "/usr/lib/python2.7/dist-packages/dbus/__init__.py", line 103, in <module>
from dbus._dbus import Bus, SystemBus, SessionBus, StarterBus
File "/usr/lib/python2.7/dist-packages/dbus/_dbus.py", line 39, in <module>
from dbus.bus import BusConnection
File "/usr/lib/python2.7/dist-packages/dbus/bus.py", line 39, in <module>
from dbus.connection import Connection
File "/usr/lib/python2.7/dist-packages/dbus/connection.py", line 37, in <module>
from dbus.proxies import ProxyObject
File "/usr/lib/python2.7/dist-packages/dbus/proxies.py", line 34, in <module>
from dbus._expat_introspect_parser import process_introspection_data
File "/usr/lib/python2.7/dist-packages/dbus/_expat_introspect_parser.py", line 26, in <module>
from xml.parsers.expat import ParserCreate
File "/usr/lib/python2.7/xml/parsers/expat.py", line 4, in <module>
from pyexpat import *
ImportError: /usr/lib/python2.7/lib-dynload/pyexpat.x86_64-linux-gnu.so: undefined symbol: XML_SetHashSalt
你为什么用终端打开呢?不是有GUI么?你的网络是不是有问题啊?希望大神们搭救你,谢谢发帖。祝你生活愉快!
因为gui打不开所以才用终端开一下看看报什么错误。网络OK的。
poloshiao
论坛版主
帖子: 18280
注册时间: 2009-08-04 16:33
送出感谢: 21 次
接收感谢: 1956 次

Re: 软件中心报错

#4

帖子 poloshiao » 2015-04-14 7:53

因为gui打不开所以才用终端开
http://manpages.ubuntu.com/manpages/mav ... ter.1.html
software-center a graphical interface for package management in Ubuntu.

按下 alt + F2
輸入
gksudo software-center

如果是第一次 使用 gksudo
請先安裝 gksu 套件

補充
1. 如果一些錯誤訊息
只要不影響操作 暫時不必理它
如果會影響操作 把錯誤訊息 貼上來
2. 要 安裝/移除/設定 套件
通常需要 root 權限
3. 在 Gnome 桌面
3-1. 非 root 使用者 要使用 root 權限 執行 圖形前端或圖行程式 請加 gksudo
gksudo 圖形前端或圖行程式
3-2. 不推薦 使用 root 登入 Gnome 桌面
parkkimlin
帖子: 3
注册时间: 2012-12-22 10:31
系统: ubuntu
送出感谢: 0
接收感谢: 0

Re: 软件中心报错

#5

帖子 parkkimlin » 2015-04-14 10:16

poloshiao 写了:
因为gui打不开所以才用终端开
http://manpages.ubuntu.com/manpages/mav ... ter.1.html
software-center a graphical interface for package management in Ubuntu.

按下 alt + F2
輸入
gksudo software-center

如果是第一次 使用 gksudo
請先安裝 gksu 套件

補充
1. 如果一些錯誤訊息
只要不影響操作 暫時不必理它
如果會影響操作 把錯誤訊息 貼上來
2. 要 安裝/移除/設定 套件
通常需要 root 權限
3. 在 Gnome 桌面
3-1. 非 root 使用者 要使用 root 權限 執行 圖形前端或圖行程式 請加 gksudo
gksudo 圖形前端或圖行程式
3-2. 不推薦 使用 root 登入 Gnome 桌面
谢谢,现在可以打开了
回复

回到 “老旧版本支持”