【已解决】do-release-upgrade 升级失败,请各位大侠帮忙!!

系统安装、升级讨论
回复
ljy1710
帖子: 4
注册时间: 2016-04-27 20:36
系统: ubuntu server 15.10
送出感谢: 1 次
接收感谢: 0

【已解决】do-release-upgrade 升级失败,请各位大侠帮忙!!

#1

帖子 ljy1710 » 2016-04-27 20:46

今天查看mail,里面有一封提示升级的邮件,所以就使用do-release-upgrade命令进行了升级,但一直提示一个依赖未安装,错误如下:

代码: 全选

Reading cache

Checking package manager
Reading package lists... Done
Building dependency tree
Reading state information... Done

Required depends is not installed

The required dependency 'apt (>= 1.0.10.2ubuntu2)' is not installed.
=== Command terminated with exit status 1 (Wed Apr 27 20:48:58 2016) ===
‘apt (>= 1.0.10.2ubuntu2)’不知道这又是个什么依赖包?update-manager-core此包已安装,请帮助解决,万分感谢。
上次由 ljy1710 在 2016-04-28 19:17,总共编辑 1 次。
rosynirvana
帖子: 893
注册时间: 2011-02-14 17:46
送出感谢: 3 次
接收感谢: 120 次

Re: do-release-upgrade 升级失败,请各位大侠帮忙!!

#2

帖子 rosynirvana » 2016-04-27 20:53

先sudo apt-get update && sudo apt-get upgrade
头像
qy117121
论坛版主
帖子: 50008
注册时间: 2007-12-14 13:40
系统: Winbuntu
来自: 志虚国乌由市
送出感谢: 18 次
接收感谢: 340 次
联系:

Re: do-release-upgrade 升级失败,请各位大侠帮忙!!

#3

帖子 qy117121 » 2016-04-27 20:54

代码: 全选

sudo apt-get install apt
就可以装上apt了
渠月 · QY    https://vz.rs/u
本人只会灌水,不负责回答问题

无聊可以点一下→ http://u.nu/ubuntu

Ubuntu 20.04 快速设置指南,请配合浏览起自动翻译使用
ljy1710
帖子: 4
注册时间: 2016-04-27 20:36
系统: ubuntu server 15.10
送出感谢: 1 次
接收感谢: 0

Re: do-release-upgrade 升级失败,请各位大侠帮忙!!

#4

帖子 ljy1710 » 2016-04-28 9:55

rosynirvana 写了:先sudo apt-get update && sudo apt-get upgrade
这条命令升级前已经执行过了。
poloshiao
论坛版主
帖子: 18280
注册时间: 2009-08-04 16:33
送出感谢: 21 次
接收感谢: 1957 次

Re: do-release-upgrade 升级失败,请各位大侠帮忙!!

#5

帖子 poloshiao » 2016-04-28 13:12

把下面指令 依序 複製 貼進終端機 執行
1. sudo apt-get -y autoremove
2. sudo apt-get -y clean
3. sudo dpkg --configure -a
4. sudo apt-get -y check
把結果直接 選取/複製 貼上來
ljy1710
帖子: 4
注册时间: 2016-04-27 20:36
系统: ubuntu server 15.10
送出感谢: 1 次
接收感谢: 0

Re: do-release-upgrade 升级失败,请各位大侠帮忙!!

#6

帖子 ljy1710 » 2016-04-28 13:19

poloshiao 写了:把下面指令 依序 複製 貼進終端機 執行
1. sudo apt-get -y autoremove
2. sudo apt-get -y clean
3. sudo dpkg --configure -a
4. sudo apt-get -y check
把結果直接 選取/複製 貼上來
我晚上回家试试看。
poloshiao
论坛版主
帖子: 18280
注册时间: 2009-08-04 16:33
送出感谢: 21 次
接收感谢: 1957 次

Re: do-release-upgrade 升级失败,请各位大侠帮忙!!

#7

帖子 poloshiao » 2016-04-28 13:43

‘apt (>= 1.0.10.2ubuntu2)’不知道这又是个什么依赖包
1. 在 Ubuntu 15.10 許多套件 都依賴 apt 套件
The required dependency 'apt (>= 1.0.10.2ubuntu2)' is not installed.
2. 新安裝 Ubuntu 時 apt 版本是 1.0.10.2ubuntu1
sudo dpkg -l | grep apt
ii apt 1.0.10.2ubuntu1 amd64 commandline package manager

3. http://packages.ubuntu.com/search?suite ... chon=names
wily (admin): commandline package manager
1.0.10.2ubuntu2 [security]: amd64 i386
如果持續更新 目前 apt 應該是 1.0.10.2ubuntu2

4. 試試

sudo apt-get install --reinstall apt

sudo dpkg -l | grep apt
看看 版本是否變成
1.0.10.2ubuntu2
这些用户感谢了作者 poloshiao 于这个帖子:
ljy1710 (2016-04-28 19:17)
评价: 3.7%
ljy1710
帖子: 4
注册时间: 2016-04-27 20:36
系统: ubuntu server 15.10
送出感谢: 1 次
接收感谢: 0

Re: do-release-upgrade 升级失败,请各位大侠帮忙!!

#8

帖子 ljy1710 » 2016-04-28 19:16

poloshiao 写了:
‘apt (>= 1.0.10.2ubuntu2)’不知道这又是个什么依赖包
1. 在 Ubuntu 15.10 許多套件 都依賴 apt 套件
The required dependency 'apt (>= 1.0.10.2ubuntu2)' is not installed.
2. 新安裝 Ubuntu 時 apt 版本是 1.0.10.2ubuntu1
sudo dpkg -l | grep apt
ii apt 1.0.10.2ubuntu1 amd64 commandline package manager

3. http://packages.ubuntu.com/search?suite ... chon=names
wily (admin): commandline package manager
1.0.10.2ubuntu2 [security]: amd64 i386
如果持續更新 目前 apt 應該是 1.0.10.2ubuntu2

4. 試試

sudo apt-get install --reinstall apt

sudo dpkg -l | grep apt
看看 版本是否變成
1.0.10.2ubuntu2

多谢高手,终于解决了。
方法如下:
:Haha :Haha :Haha :Haha :Haha :Haha

1,在/etc/apt/sources.list中加入
deb http://security.ubuntu.com/ubuntu wily-security main
2,重新update
3,再执行do-release-upgrade即可。

:Haha :Haha :Haha :Haha :Haha :Haha
poloshiao
论坛版主
帖子: 18280
注册时间: 2009-08-04 16:33
送出感谢: 21 次
接收感谢: 1957 次

Re: 【已解决】do-release-upgrade 升级失败,请各位大侠帮忙!!

#9

帖子 poloshiao » 2016-04-28 22:16

恭喜你 ?
rosynirvana 写了:先sudo apt-get update && sudo apt-get upgrade
这条命令升级前已经执行过了。
1,在/etc/apt/sources.list中加入
deb http://security.ubuntu.com/ubuntu wily-security main
2,重新update
3,再执行do-release-upgrade即可。
表示 你前面的 /etc/apt/sources.list 沒有 wily-security ?
這個有點奇怪
回复

回到 “系统安装和升级”