ubuntu18.04下如何使用TL-WDN5200H免驱版usb无线网卡

包含网卡/无线网的网络问题和ADSL/校园网/宽带拨号支持及代理/共享等网络使用问题
onlylove
论坛版主
帖子: 4528
注册时间: 2007-01-14 16:23
送出感谢: 0
接收感谢: 110 次

Re: ubuntu18.04下如何使用TL-WDN5200H免驱版usb无线网卡

#16

帖子 onlylove » 2019-03-03 14:07

我觉得需要上图手把手了……

来,我把7楼的前面步骤演示给你看
第一步 下载驱动,安装编译环境
prepare.jpg
第二步,解压缩驱动,在目标目录里打开终端,输入make
make_start.jpg
第三步,编译结束
make_done.jpg
编译过程会有一些报错

至此,驱动已经编译好了,再执行make install就可以安装了

现在再来看你的出错信息
root@zheng-computer:/home/zheng/Downloads/rtl8821cu-master# sudo make
make CFLAGS_FLOAT="-mhard-float -mfloat-abi=hard" V=1 ARCH=x86_64 CROSS_COMPILE= -C /lib/modules/4.15.0-45-generic/build M=/home/zheng/Downloads/rtl8821cu-master modules
make[1]: 进入目录“/usr/src/linux-headers-4.15.0-45-generic”
Makefile:975: "Cannot use CONFIG_STACK_VALIDATION=y, please install libelf-dev, libelf-devel or elfutils-libelf-devel"
test -e include/generated/autoconf.h -a -e include/config/auto.conf || ( \
echo >&2; \
echo >&2 " ERROR: Kernel configuration is invalid."; \
echo >&2 " include/generated/autoconf.h or include/config/auto.conf are missing.";\
echo >&2 " Run 'make oldconfig && make prepare' on kernel src to fix it."; \
echo >&2 ; \
/bin/false)
只能说,你没装全必要的包,或者依赖的版本有问题,肯定编译不会过的,而且都用root用户了,咋还要sudo(不提倡用root用户,但是如果你一定要用……随你吧)
这些用户感谢了作者 onlylove 于这个帖子:
郑小喷 (2019-03-04 20:16)
评价: 3.7%
郑小喷
帖子: 16
注册时间: 2018-11-21 13:16
系统: 18.04
送出感谢: 4 次
接收感谢: 0

Re: ubuntu18.04下如何使用TL-WDN5200H免驱版usb无线网卡

#17

帖子 郑小喷 » 2019-03-04 17:35

onlylove 写了:
2019-03-03 14:07
我觉得需要上图手把手了……

来,我把7楼的前面步骤演示给你看
第一步 下载驱动,安装编译环境
prepare.jpg
第二步,解压缩驱动,在目标目录里打开终端,输入make
make_start.jpg
第三步,编译结束
make_done.jpg
编译过程会有一些报错

至此,驱动已经编译好了,再执行make install就可以安装了

现在再来看你的出错信息
root@zheng-computer:/home/zheng/Downloads/rtl8821cu-master# sudo make
make CFLAGS_FLOAT="-mhard-float -mfloat-abi=hard" V=1 ARCH=x86_64 CROSS_COMPILE= -C /lib/modules/4.15.0-45-generic/build M=/home/zheng/Downloads/rtl8821cu-master modules
make[1]: 进入目录“/usr/src/linux-headers-4.15.0-45-generic”
Makefile:975: "Cannot use CONFIG_STACK_VALIDATION=y, please install libelf-dev, libelf-devel or elfutils-libelf-devel"
test -e include/generated/autoconf.h -a -e include/config/auto.conf || ( \
echo >&2; \
echo >&2 " ERROR: Kernel configuration is invalid."; \
echo >&2 " include/generated/autoconf.h or include/config/auto.conf are missing.";\
echo >&2 " Run 'make oldconfig && make prepare' on kernel src to fix it."; \
echo >&2 ; \
/bin/false)
只能说,你没装全必要的包,或者依赖的版本有问题,肯定编译不会过的,而且都用root用户了,咋还要sudo(不提倡用root用户,但是如果你一定要用……随你吧)
多谢斑竹,百忙之中抽时间来给我回复!本身这一块确实是小白, :Haha 感谢您的“手把手” :em42 ,我也还是上图吧。这次不用root用户登录果然编译没有报错了!最后执行sudo make install 命令,果然可以了!再次感谢您不厌其烦的回复!
郑小喷
帖子: 16
注册时间: 2018-11-21 13:16
系统: 18.04
送出感谢: 4 次
接收感谢: 0

Re: ubuntu18.04下如何使用TL-WDN5200H免驱版usb无线网卡

#18

帖子 郑小喷 » 2019-03-04 20:23

onlylove 写了:
2019-03-03 14:07
我觉得需要上图手把手了……

来,我把7楼的前面步骤演示给你看
第一步 下载驱动,安装编译环境
prepare.jpg
第二步,解压缩驱动,在目标目录里打开终端,输入make
make_start.jpg
第三步,编译结束
make_done.jpg
编译过程会有一些报错

至此,驱动已经编译好了,再执行make install就可以安装了

现在再来看你的出错信息
root@zheng-computer:/home/zheng/Downloads/rtl8821cu-master# sudo make
make CFLAGS_FLOAT="-mhard-float -mfloat-abi=hard" V=1 ARCH=x86_64 CROSS_COMPILE= -C /lib/modules/4.15.0-45-generic/build M=/home/zheng/Downloads/rtl8821cu-master modules
make[1]: 进入目录“/usr/src/linux-headers-4.15.0-45-generic”
Makefile:975: "Cannot use CONFIG_STACK_VALIDATION=y, please install libelf-dev, libelf-devel or elfutils-libelf-devel"
test -e include/generated/autoconf.h -a -e include/config/auto.conf || ( \
echo >&2; \
echo >&2 " ERROR: Kernel configuration is invalid."; \
echo >&2 " include/generated/autoconf.h or include/config/auto.conf are missing.";\
echo >&2 " Run 'make oldconfig && make prepare' on kernel src to fix it."; \
echo >&2 ; \
/bin/false)
只能说,你没装全必要的包,或者依赖的版本有问题,肯定编译不会过的,而且都用root用户了,咋还要sudo(不提倡用root用户,但是如果你一定要用……随你吧)
现在是换个电脑执行最后一行命令sudo modprobe 8821cu就报错,这大概是什么情况啊?
2019-03-04 20-23-01屏幕截图.png
2019-03-04 20-22-51屏幕截图.png
onlylove
论坛版主
帖子: 4528
注册时间: 2007-01-14 16:23
送出感谢: 0
接收感谢: 110 次

Re: ubuntu18.04下如何使用TL-WDN5200H免驱版usb无线网卡

#19

帖子 onlylove » 2019-03-04 21:43

这个我不太清楚,问下 @astolia 看看
头像
astolia
论坛版主
帖子: 3640
注册时间: 2008-09-18 13:11
送出感谢: 1 次
接收感谢: 609 次

Re: ubuntu18.04下如何使用TL-WDN5200H免驱版usb无线网卡

#20

帖子 astolia » 2019-03-05 10:13

你这样编译出来的驱动没签名,如果你是用的uefi且开启了secure boot就会这样
其他相对少见的情况是驱动需要的资源被占用,modprobe后用dmesg看报错信息
郑小喷
帖子: 16
注册时间: 2018-11-21 13:16
系统: 18.04
送出感谢: 4 次
接收感谢: 0

Re: ubuntu18.04下如何使用TL-WDN5200H免驱版usb无线网卡

#21

帖子 郑小喷 » 2019-03-17 15:01

astolia 写了:
2019-03-05 10:13
你这样编译出来的驱动没签名,如果你是用的uefi且开启了secure boot就会这样
其他相对少见的情况是驱动需要的资源被占用,modprobe后用dmesg看报错信息
一时不知该怎么表达了!首先,还是从心底里感谢你们无私的回复!其次是抱歉,这么久才给您回复!还有就是用dmesg命令查看后,内容有点多,有点犹豫该用什么方式呈现给您?想了想还是单独存文件里,上传下,您抽空看下吧,可行?内容实在是有点多,我也看不明白!如果您实在没时间,就不回复了!我再想其他办法。我这个机器装的双系统,Windows10+Ubuntu18.04(后来升级成18.10),是uefi启动模式!在Windows下安装了vmware虚拟机中安装了Ubuntu18.04用这5200H网卡没有问题,在公司另外一台电脑中(也是双系统:Windows7+Ubuntu18.04),不过那是legacy启动模式,也没有问题!如果您有时间,还是得劳烦您帮我这小白看看。实在是给你们添了很多麻烦!抱歉+感谢!
附件
dmesg命令查看.doc
(185 KiB) 下载 2 次
头像
astolia
论坛版主
帖子: 3640
注册时间: 2008-09-18 13:11
送出感谢: 1 次
接收感谢: 609 次

Re: ubuntu18.04下如何使用TL-WDN5200H免驱版usb无线网卡

#22

帖子 astolia » 2019-03-18 10:44

郑小喷 写了:
2019-03-17 15:01
astolia 写了:
2019-03-05 10:13
你这样编译出来的驱动没签名,如果你是用的uefi且开启了secure boot就会这样
其他相对少见的情况是驱动需要的资源被占用,modprobe后用dmesg看报错信息
我这个机器装的双系统,Windows10+Ubuntu18.04(后来升级成18.10),是uefi启动模式!
语文阅读能力这么差,红字部分看不懂吗?你开了secure boot就必然会这样。dmesg是万一你系统不是uefi或者没开secure boot才需要看具体的错误信息。
不过你demsg输出里已经写明白了
[ 0.000000] secureboot: Secure boot enabled
自己去bios里把secure boot关了就是了。
这些用户感谢了作者 astolia 于这个帖子:
郑小喷 (2019-03-18 13:35)
评价: 3.7%
郑小喷
帖子: 16
注册时间: 2018-11-21 13:16
系统: 18.04
送出感谢: 4 次
接收感谢: 0

Re: ubuntu18.04下如何使用TL-WDN5200H免驱版usb无线网卡

#23

帖子 郑小喷 » 2019-03-19 20:03

astolia 写了:
2019-03-18 10:44
郑小喷 写了:
2019-03-17 15:01
astolia 写了:
2019-03-05 10:13
你这样编译出来的驱动没签名,如果你是用的uefi且开启了secure boot就会这样
其他相对少见的情况是驱动需要的资源被占用,modprobe后用dmesg看报错信息
我这个机器装的双系统,Windows10+Ubuntu18.04(后来升级成18.10),是uefi启动模式!
语文阅读能力这么差,红字部分看不懂吗?你开了secure boot就必然会这样。dmesg是万一你系统不是uefi或者没开secure boot才需要看具体的错误信息。
不过你demsg输出里已经写明白了
[ 0.000000] secureboot: Secure boot enabled
自己去bios里把secure boot关了就是了。
首先,还是感谢您的回复!您批评的是,我的个人电脑无线网卡的问题已经解决了!但是还有台电脑用的是legacy启动模式,secure boot关闭状态,运行sudo modprobe 8821cu 显示modprobe: FATAL: Module 8821cu not found in directory /lib/modules/4.15.0-46-generic,我的这台电脑是Dell precision 5820工作站,安装的是18.04系统,真的很麻烦!我尝试看了下dmesg命令输出的内容,看不明白!您要有时间能否再帮忙看看?在执行sudo modprobe 8821cu这条命令之前,执行之前的命令都正常!我的这种情况是不是您说的那种驱动需要的资源被占用了?
附件
Screenshot from 2019-03-19 19-46-32.png
dell precision 5820工作站dmesg查询.doc
(216.5 KiB) 下载 2 次
头像
astolia
论坛版主
帖子: 3640
注册时间: 2008-09-18 13:11
送出感谢: 1 次
接收感谢: 609 次

Re: ubuntu18.04下如何使用TL-WDN5200H免驱版usb无线网卡

#24

帖子 astolia » 2019-03-20 9:53

能不能阅读理解一下报错信息?not found就告诉了你驱动文件没有找到。十有八九是你做了16楼的操作后,没有看到或忘了后面还有sudo make install
回复

回到 “网卡问题以及网络和拨号”