跪求大神指点,双系统(Windows server+Ubuntu server)始终无法启动Ubuntu

系统安装、升级讨论
回复
jupiter1985
帖子: 1
注册时间: 2019-03-28 15:49
系统: win 7
送出感谢: 0
接收感谢: 0

跪求大神指点,双系统(Windows server+Ubuntu server)始终无法启动Ubuntu

#1

帖子 jupiter1985 » 2019-03-28 16:42

大家好!我以前没用过Linux系统,是个技术小白。最近在给办公室一台服务器安装Windows server 2012 R2 + Ubuntu server 16.04 双系统,死活不能正常启动Ubuntu,已经折腾几天了,百度N 遍,始终解决不了,求救各位大神!
服务器情况和我的安装情况大致如下:
1、服务器有两块硬盘,其中1块200多G,另外一块是磁盘阵列,大概有8T。
2、安装Windows server:用U盘制作启动盘,已正常安装系统,安装在第1块200多G的硬盘里。
3、接着安装Ubuntu server 16.04:按照网上教程,也是制作U盘启动盘,计划安装在第2块8T硬盘中。前面比较简单的一些设置略过,在磁盘分区设置时,硬盘划分四个,按顺序如下:/boot,/ ,swap ,/home 。
图片1.jpg
安装的最后一步选择 boot loader 的安装位置,我选了 挂载点/boot ,也就是 /dev/sdb ,即第二块硬盘默认第一个分区。

安装完Ubuntu 后重启,直接进入Windows server ,没有显示Ubuntu 启动选择项。按照网上教程,又下载了 EasyBCD,“添加新条目”——“Linux/BSD”,类型选grub2,驱动器选择第二个硬盘的第1个分区,也就是 /boot
图片2.jpg
重启以后,可以看到两个系统启动的选择项。
图片3.jpg
但是选了Ubuntu 以后,进不了Ubuntu系统,只显示 grub> 命令行。
图片4.jpg
百度了一下,说是grub引导文件损坏。这怎么可能呢?刚刚才安装完成啊。按照网上的做法,输入指令 ls ,说是会列出所有磁盘分区,比如(hd0,1),(hd0,5),(hd0,3) 等,找到Ubuntu安装分区,再然后找 grub 文件等等...... 但是我操作的情况完全不一样,输入 ls ,显示一大串类似文件夹的名字,并没有类似(hd0,1)这一类的分区。网上教程提供的其他指令的输出结果,也都完全跟我现实的操作情况不一样!
照片5.jpg
究竟怎样才能正常进入Ubuntu系统?非常崩溃,已经百度了无数遍了,求各位大神搭救!不胜感谢!
fuhuizn
帖子: 839
注册时间: 2006-01-06 22:55
系统: ubuntu
送出感谢: 0
接收感谢: 20 次
联系:

Re: 跪求大神指点,双系统(Windows server+Ubuntu server)始终无法启动Ubuntu

#2

帖子 fuhuizn » 2019-03-30 15:54

boot loader 的安装位置,选 /dev/sda
hadolop
帖子: 1
注册时间: 2019-05-14 10:12
系统: windows server2012
送出感谢: 0
接收感谢: 0

Re: 跪求大神指点,双系统(Windows server+Ubuntu server)始终无法启动Ubuntu

#3

帖子 hadolop » 2019-05-14 10:26

前辈,我也遇到这样得问题。在windows server 2012R2上安装Ubuntu18.02,重启开机直接启动 Ubuntu boot,然后出现GNU GRUB2 ,grub>进入不了系统。而且连原来得windows server 也进入不了了。 查看BIOS,发现没有了windows boot manager 。请教各位大神?
头像
goldfox_79
帖子: 1967
注册时间: 2005-10-16 8:26
来自: 地球
送出感谢: 0
接收感谢: 1 次

Re: 跪求大神指点,双系统(Windows server+Ubuntu server)始终无法启动Ubuntu

#4

帖子 goldfox_79 » 2019-05-14 12:14

jupiter1985 写了:
2019-03-28 16:42
大家好!我以前没用过Linux系统,是个技术小白。最近在给办公室一台服务器安装Windows server 2012 R2 + Ubuntu server 16.04 双系统,死活不能正常启动Ubuntu,已经折腾几天了,百度N 遍,始终解决不了,求救各位大神!
服务器情况和我的安装情况大致如下:
1、服务器有两块硬盘,其中1块200多G,另外一块是磁盘阵列,大概有8T。
2、安装Windows server:用U盘制作启动盘,已正常安装系统,安装在第1块200多G的硬盘里。
3、接着安装Ubuntu server 16.04:按照网上教程,也是制作U盘启动盘,计划安装在第2块8T硬盘中。前面比较简单的一些设置略过,在磁盘分区设置时,硬盘划分四个,按顺序如下:/boot,/ ,swap ,/home 。
图片1.jpg
安装的最后一步选择 boot loader 的安装位置,我选了 挂载点/boot ,也就是 /dev/sdb ,即第二块硬盘默认第一个分区。

安装完Ubuntu 后重启,直接进入Windows server ,没有显示Ubuntu 启动选择项。按照网上教程,又下载了 EasyBCD,“添加新条目”——“Linux/BSD”,类型选grub2,驱动器选择第二个硬盘的第1个分区,也就是 /boot
图片2.jpg
重启以后,可以看到两个系统启动的选择项。
图片3.jpg
但是选了Ubuntu 以后,进不了Ubuntu系统,只显示 grub> 命令行。
图片4.jpg
百度了一下,说是grub引导文件损坏。这怎么可能呢?刚刚才安装完成啊。按照网上的做法,输入指令 ls ,说是会列出所有磁盘分区,比如(hd0,1),(hd0,5),(hd0,3) 等,找到Ubuntu安装分区,再然后找 grub 文件等等...... 但是我操作的情况完全不一样,输入 ls ,显示一大串类似文件夹的名字,并没有类似(hd0,1)这一类的分区。网上教程提供的其他指令的输出结果,也都完全跟我现实的操作情况不一样!
照片5.jpg
究竟怎样才能正常进入Ubuntu系统?非常崩溃,已经百度了无数遍了,求各位大神搭救!不胜感谢!
从照片看你进入的是windows系统所在的分区
回复

回到 “系统安装和升级”