当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 1 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [分享]搞定Java应用程序的中文显示及中文输入问题
帖子发表于 : 2006-04-10 22:07 
头像

注册: 2005-07-28 14:40
帖子: 39
送出感谢: 0 次
接收感谢: 0 次
一、中文显示参照http://forum.ubuntu.org.cn/viewtopic.php?t=6338解决,使用JDK和fireflysung字体。

二、中文输入问题解决方法如下:

* 问题描述:使用Ctrl+Space无法呼出scim,因此无法在Java应用程序中输入中文。
* 原因分析:(1).可能是由于该Java应用程序将Ctrl+Space定义成了快捷键,所以与scim存在冲突。
       (2).由于scim XIM支持模块没能自动加载,故导致在Java应用程序中无法呼出scim。
* 解决方案:针对第一种原因,只要修改scim的呼出热键,或者修改Java应用程序中的快捷键,即可解决问题。

而第二种原因可以按如下方法处理:

1.检查XMODIFIER的设置

export | grep XMODIFIER | grep “@IM=SCIM” | wc -l

输出应该为1。如果不是,则检查系统配置,推荐使用utf-8区域。

2.如果上一步输出无误,则输入下列命令:

ps aux | grep “scim-launcher.*-f x11″ | grep -v grep | wc -l

此输出应该大于或等于1。如果不是,如我的输出为0,则说明scim XIM支持模块没有自动载入。你可以手动载入它:

scim -d -c socket -f x11 -e socket

此时,我启动Java应用程序,试了试scim,已经可以输入中文了。但如果每次都手动加载还是比较麻烦,所以我们考虑让系统自动加载它。

在/etc/X11/Xsession.d中创建75custom-scim_init文件,包括如下内容:

export XMODIFIERS=”@IM=SCIM”
export GTK_IM_MODULE=”scim”
export XIM_PROGRAM=”scim -d”

转到System->Preferences->Sessions,选择Startup Programs,添加scim -d,并保留顺序为50。

登录root终端,输入下列命令:

gtk-query-immodules-2.0 > /etc/gtk-2.0/gtk.immodules

重新启动系统,一切正常,cool!

见图:

图片

图片

更详细的请查看:http://softloc.cn/index.php/archives/java-chinese.html

仅供参考。


_________________
===>
Reading http://linuxtoy.org


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 1 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译