请教两个问题?

为当前最终发行版之前的所有版本提供支持
回复
handi
帖子: 2
注册时间: 2005-07-28 21:12
送出感谢: 0
接收感谢: 0

请教两个问题?

#1

帖子 handi » 2005-07-30 15:26

1. ubuntu能否使用debian的源?
2. 官方源和镜像源包都同步吗?

记得debian下可以直接用
apt-get install stlport

但是ubuntu下面好象不可以
yongyi
帖子: 3025
注册时间: 2005-05-07 23:57
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 yongyi » 2005-07-30 17:11

1.不建议使用,除非你说我自担风险
2.应该是同步的。相关技术方面叶兄清楚点。

或者你需要的是:
sudo apt-get install libstlport4.6

请多了解一下ubuntu。主页的文档很丰富。
独自看一看大海
总想起身边走在路上的朋友
Lenovo E290-420[Celeron-M420/256M/60G/Intel GMA950]
handi
帖子: 2
注册时间: 2005-07-28 21:12
送出感谢: 0
接收感谢: 0

#3

帖子 handi » 2005-07-30 20:59

非常感谢

yongyi兄能否说明一下使用debian源的风险在哪里?

是否ubuntu和debian的deb格式不兼容?

关于stlport.

源里有两个包可以选择libstlport4.6 和libstlport4.6-dev

我想后面一个是我要的,前面一个libstlport4.6是系统默认安装就有的

看来这个和debian的包命名还是有不少区别的,慢慢适应吧


PS:ubuntu的汉化和字体安装很方便,包更新的也很快,尤其对于nb的支持让我很满意
头像
millenniumdark
论坛版主
帖子: 4159
注册时间: 2005-07-02 14:41
系统: Ubuntu 14.04 (Kylin)
送出感谢: 42 次
接收感谢: 9 次
联系:

#4

帖子 millenniumdark » 2005-07-31 20:33

handi 写了:
是否ubuntu和debian的deb格式不兼容?
應該是一樣的

一般來說用debian的源沒什么大風險。

還有,這里的源步調好像快一點
yongyi
帖子: 3025
注册时间: 2005-05-07 23:57
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 yongyi » 2005-07-31 21:00

deb 格式肯定是一样的,可以安装使用(如果你能在某些时候能解决依赖)。不建议混用,只是希望系统稳定点。不要认为ubuntu就不能安装Debian的软件包。

正如你说的,有些地方命令也不同,这可能令依赖关系混乱。Debian跟ubuntu 的依赖(特别在版本上)不大相同。
相信不少兄弟都遇到过,我今天就遇上了,下一个Debian 软件包,但有些依赖要求 挺高的,以ubuntu hoary 的源是无法安装,甚至连breezy 也没这么高(我今天就是这情况)。那么如果勉强用Debian的源来解决依赖关系去安装的话,很可能对以后系统的维护(安装卸载软件)以及升级会有影响的。

曾经有Debian 的用户混用了 ubuntu 源而令系统down 掉。(倒没有人特意说ubuntu 用了debian 的源而down了系统 :lol:

当然,linux 并不会绑死人,你还是能用Debian 包,也可以用rpm包,但就得面对错综复杂的依赖关系了。

BTW:以上是个人使用经验,不代表官方立场。
独自看一看大海
总想起身边走在路上的朋友
Lenovo E290-420[Celeron-M420/256M/60G/Intel GMA950]
回复

回到 “老旧版本支持”