Ubuntu Server 14.01 LTS 同时有2.7和3.4两个python版本,怎么确定哪个是在用的

Python/PHP/Perl 开发与设计
回复
lseed
帖子: 7
注册时间: 2010-05-26 15:15
送出感谢: 0
接收感谢: 0

Ubuntu Server 14.01 LTS 同时有2.7和3.4两个python版本,怎么确定哪个是在用的

#1

帖子 lseed » 2015-01-28 22:04

不好意思,问个小白的问题。
这两天在安装ReviewBoard,检查easy_install的安装包才发现系统里有python2.7 和python3.4两个版本,通过easy_install安装的包都在python2.7/dist-packages文件夹下,是不是说明目前主要在用的是python2.7呢?
python3.4是不是ubuntu server 14.01自带的?我能删除这个3.4版本吗?删除这个版本会不会对已经安装一些其他应用有影响呢?
谢谢!!
头像
月下叹逍遥
论坛版主
帖子: 33994
注册时间: 2010-10-07 14:23
系统: Archdows10
来自: 某系某星某洲某国某省某市
送出感谢: 8 次
接收感谢: 63 次
联系:

Re: Ubuntu Server 14.01 LTS 同时有2.7和3.4两个python版本,怎么确定哪个是在用的

#2

帖子 月下叹逍遥 » 2015-01-28 22:53

1,调用python的话,默认用的是2.7
2,自带3.4,调用命令为python3或者python3.4
3,一般不要删3.4,有些程序会依赖3.4
心似浮云常自在,意如流水任东西。
此事背后一定有个天大的咪咪
广告:
1、走过路过,不要错过,dropbox网盘2.25G大放送
py大法好,退C保平安
java多妖孽,VB本异端
日诵一千遍,快活似神仙
poloshiao
论坛版主
帖子: 18280
注册时间: 2009-08-04 16:33
送出感谢: 21 次
接收感谢: 1956 次

Re: Ubuntu Server 14.01 LTS 同时有2.7和3.4两个python版本,怎么确定哪个是在用的

#3

帖子 poloshiao » 2015-01-29 6:15

怎么确定哪个是在用的
試試
sudo ls -al /usr/bin/python
看看 軟連結到 python2.7 或 python3.4
lseed
帖子: 7
注册时间: 2010-05-26 15:15
送出感谢: 0
接收感谢: 0

Re: Ubuntu Server 14.01 LTS 同时有2.7和3.4两个python版本,怎么确定哪个是在用的

#4

帖子 lseed » 2015-01-29 13:03

月下叹逍遥 写了:1,调用python的话,默认用的是2.7
2,自带3.4,调用命令为python3或者python3.4
3,一般不要删3.4,有些程序会依赖3.4
好的,非常感谢啊!!
lseed
帖子: 7
注册时间: 2010-05-26 15:15
送出感谢: 0
接收感谢: 0

Re: Ubuntu Server 14.01 LTS 同时有2.7和3.4两个python版本,怎么确定哪个是在用的

#5

帖子 lseed » 2015-01-29 13:03

月下叹逍遥 写了:1,调用python的话,默认用的是2.7
2,自带3.4,调用命令为python3或者python3.4
3,一般不要删3.4,有些程序会依赖3.4
好的,非常感谢啊!!
lseed
帖子: 7
注册时间: 2010-05-26 15:15
送出感谢: 0
接收感谢: 0

Re: Ubuntu Server 14.01 LTS 同时有2.7和3.4两个python版本,怎么确定哪个是在用的

#6

帖子 lseed » 2015-01-29 13:06

月下叹逍遥 写了:1,调用python的话,默认用的是2.7
2,自带3.4,调用命令为python3或者python3.4
3,一般不要删3.4,有些程序会依赖3.4
好的,非常感谢!!
lseed
帖子: 7
注册时间: 2010-05-26 15:15
送出感谢: 0
接收感谢: 0

Re: Ubuntu Server 14.01 LTS 同时有2.7和3.4两个python版本,怎么确定哪个是在用的

#7

帖子 lseed » 2015-01-29 13:08

月下叹逍遥 写了:1,调用python的话,默认用的是2.7
2,自带3.4,调用命令为python3或者python3.4
3,一般不要删3.4,有些程序会依赖3.4
好的,非常感谢!!
lseed
帖子: 7
注册时间: 2010-05-26 15:15
送出感谢: 0
接收感谢: 0

Re: Ubuntu Server 14.01 LTS 同时有2.7和3.4两个python版本,怎么确定哪个是在用的

#8

帖子 lseed » 2015-01-29 13:10

月下叹逍遥 写了:1,调用python的话,默认用的是2.7
2,自带3.4,调用命令为python3或者python3.4
3,一般不要删3.4,有些程序会依赖3.4
好的,非常感谢!!
lseed
帖子: 7
注册时间: 2010-05-26 15:15
送出感谢: 0
接收感谢: 0

Re: Ubuntu Server 14.01 LTS 同时有2.7和3.4两个python版本,怎么确定哪个是在用的

#9

帖子 lseed » 2015-01-29 14:05

是2.7,太感谢了!
poloshiao 写了:
怎么确定哪个是在用的
試試
sudo ls -al /usr/bin/python
看看 軟連結到 python2.7 或 python3.4
ethan2016s
帖子: 50
注册时间: 2015-10-17 19:04
系统: ubuntu win7
送出感谢: 0
接收感谢: 0

Re: Ubuntu Server 14.01 LTS 同时有2.7和3.4两个python版本,怎么确定哪个是在用的

#10

帖子 ethan2016s » 2015-10-28 15:30

想用python2的在终端键入python2或者python2.7即可
想用python3的在终端键入python3或者python3.4即可
====================================================
jacob2022s@gmail.com
回复

回到 “Python/Php/Perl”