系统升级过程中,提示ia32-libs错误,请问高手如何解决

系统安装、升级讨论
回复
xianpn
帖子: 10
注册时间: 2012-08-25 16:17
送出感谢: 0
接收感谢: 0

系统升级过程中,提示ia32-libs错误,请问高手如何解决

#1

帖子 xianpn » 2012-08-25 17:30

我的系统是ubuntu 12.04 64位, 我首先apt-get update后,点选系统“有可用更新”,更新一半后,系统提示ia32-libs错误,然后按照提示输入
apt-get install -f尝试修复,但是最终结果都不是无法修复,现在使用apt-get安装软件都提示有故障,需要需修。我已经试过新立得尝试修复,但是都不行,望高手指点。
以下是错误内容
matthew@matthew-ThinkPad-X201:~$ sudo apt-get install ia32-libs
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
正在读取状态信息... 完成
您可能需要运行“apt-get -f install”来纠正下列错误:
下列软件包有未满足的依赖关系:
ia32-libs : 依赖: ia32-libs-i386 但无法安装它
E: 有未能满足的依赖关系。请尝试不指明软件包的名字来运行“apt-get -f install”(也可以指定一个解决办法)。
matthew@matthew-ThinkPad-X201:~$ sudo apt-get -f install
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
正在读取状态信息... 完成
正在更正依赖关系... 完成
下列软件包是自动安装的并且现在不需要了:
libao-common odbcinst1debian2 libopenal-data odbcinst esound-common
mysql-common
使用'apt-get autoremove'来卸载它们
下列软件包将被【卸载】:
ia32-libs
升级了 0 个软件包,新安装了 0 个软件包,要卸载 1 个软件包,有 1024 个软件包未被升级。
有 1 个软件包没有被完全安装或卸载。
解压缩后将会空出 41.0 kB 的空间。
您希望继续执行吗?[Y/n]y
dpkg: error: 配置错误:/etc/dpkg/dpkg.cfg.d/multiarch:1:未知选项 foreign-architecture
E: Sub-process /usr/bin/dpkg returned an error code (2)
xianpn
帖子: 10
注册时间: 2012-08-25 16:17
送出感谢: 0
接收感谢: 0

Re: 系统升级过程中,提示ia32-libs错误,请问高手如何解决

#2

帖子 xianpn » 2012-08-28 14:48

解决了,原来最后原因是软件源的问题
q3262157
帖子: 8
注册时间: 2012-10-15 22:23
系统: ubuntu
送出感谢: 0
接收感谢: 0

Re: 系统升级过程中,提示ia32-libs错误,请问高手如何解决

#3

帖子 q3262157 » 2012-10-16 18:24

能够说一下是怎么解决的吗?我也碰到了这个问题,弄了很久都没解决,因为我是新手,希望您能写一下详细步骤与操作指令,万分感谢!
头像
Max Xu
帖子: 1
注册时间: 2013-08-23 16:29
系统: Ubuntu 12.04
送出感谢: 0
接收感谢: 0

Re: 系统升级过程中,提示ia32-libs错误,请问高手如何解决

#4

帖子 Max Xu » 2013-08-30 17:26

q3262157 写了:能够说一下是怎么解决的吗?我也碰到了这个问题,弄了很久都没解决,因为我是新手,希望您能写一下详细步骤与操作指令,万分感谢!
求解决方案啊!!!
回复

回到 “系统安装和升级”