求助:更新失败

系统安装、升级讨论
版面规则
我们都知道新人的确很菜,也喜欢抱怨,并且带有浓厚的Windows习惯,但既然在这里询问,我们就应该有责任帮助他们解决问题,而不是直接泼冷水、简单的否定或发表对解决问题没有任何帮助的帖子。乐于分享,以人为本,这正是Ubuntu的精神所在。
回复
lovealone
帖子: 20
注册时间: 2009-08-27 12:56
送出感谢: 0
接收感谢: 0

求助:更新失败

#1

帖子 lovealone » 2016-05-20 14:36

ubuntu 16.10更新失败,提示信息如下:
(正在读取数据库 ... 系统当前共安装有 320000 个文件和目录。)
正准备解包 .../texlive-fonts-extra-doc_2016.20160512-1_all.deb ...
正在将 texlive-fonts-extra-doc (2016.20160512-1) 解包到 (2015.20160320-1) 上 ...
dpkg: 处理归档 /var/cache/apt/archives/texlive-fonts-extra-doc_2016.20160512-1_all.deb (--unpack)时出错:
正试图覆盖 /usr/share/doc/texlive-doc/latex/mweights/README,它同时被包含于软件包 texlive-latex-extra-doc 2015.20160320-1
dpkg-deb:错误:子进程 粘贴 被信号(断开的管道) 终止了
在处理时有错误发生:
/var/cache/apt/archives/texlive-fonts-extra-doc_2016.20160512-1_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
使用sudo apt -f upgrade或者sudo apt -f install都不行
头像
vickycq
帖子: 4507
注册时间: 2011-03-20 13:12
系统: Debian
来自: 山东省寿光县
送出感谢: 100 次
接收感谢: 991 次
联系:

Re: 求助:更新失败

#2

帖子 vickycq » 2016-05-20 14:52

texlive-fonts-extra-doc 打包有问题 参见 https://bugs.debian.org/cgi-bin/bugrepo ... bug=824137

可临时强制覆盖

代码: 全选

apt-get -o Dpkg::Options::="--force-overwrite" -f install
Debian 中文论坛 - forums.debiancn.org
欢迎所有 Debian GNU/Linux 用户
回复