gedit 提示错误,有解决方案吗?

18.04、16.04、14.04
回复
ygfly
帖子: 73
注册时间: 2008-11-02 8:52
送出感谢: 5 次
接收感谢: 0

gedit 提示错误,有解决方案吗?

#1

帖子 ygfly » 2016-10-16 10:11

编辑文件提示“Set document metadata failed: 不支持设置属性 metadata::gedit-spell-enabled”错误,
网络搜索没有找到解决方案,求帮。
头像
vickycq
帖子: 4507
注册时间: 2011-03-20 13:12
系统: Debian
来自: 山东省寿光县
送出感谢: 100 次
接收感谢: 990 次
联系:

Re: gedit 提示错误,有解决方案吗?

#2

帖子 vickycq » 2016-10-16 10:53

ygfly 写了:编辑文件提示“Set document metadata failed: 不支持设置属性 metadata::gedit-spell-enabled”错误,
是否使用了 sudo 或 gksu?若使用了 sudo 或 gksu,则属正常。因使用 sudo 或 gksu 运行图形界面应用程序时多会出现各类问题。
这些用户感谢了作者 vickycq 于这个帖子:
ygfly (2016-10-16 14:37)
评价: 3.7%
Debian 中文论坛 - forums.debiancn.org
欢迎所有 Debian GNU/Linux 用户
ygfly
帖子: 73
注册时间: 2008-11-02 8:52
送出感谢: 5 次
接收感谢: 0

Re: gedit 提示错误,有解决方案吗?

#3

帖子 ygfly » 2016-10-16 12:49

用了 sudo,明白了,多谢!
poloshiao
论坛版主
帖子: 18280
注册时间: 2009-08-04 16:33
送出感谢: 21 次
接收感谢: 1957 次

Re: gedit 提示错误,有解决方案吗?

#4

帖子 poloshiao » 2016-10-16 19:45

gedit 提示错误
1. 如果不必使用 root 權限 例如
gedit ~/myown.txt
2. 如果需要使用 root 權限 加 gksudo 例如
gksudo gedit /etc/myown.txt
2-1. gedit 是 gnome 圖形界面程式 所以加 gksudo
2-2. 第一次使用 gksudo 需要先安裝 gksu 套件

3. 如果出現訊息 但是打開 gedit 沒問題 一般暫時不必理會出現的訊息
这些用户感谢了作者 poloshiao 于这个帖子:
ygfly (2016-10-18 16:12)
评价: 3.7%
头像
TeliuTe
论坛版主
帖子: 7595
注册时间: 2007-11-25 13:29
系统: 14/16/18/Fedroa22/w7
来自: 新疆博乐
送出感谢: 30 次
接收感谢: 106 次
联系:

Re: gedit 提示错误,有解决方案吗?

#5

帖子 TeliuTe » 2016-10-17 0:22

看提示像是拼写检查,到 编辑-首选项-插件 里关闭拼写检查试试
poloshiao
论坛版主
帖子: 18280
注册时间: 2009-08-04 16:33
送出感谢: 21 次
接收感谢: 1957 次

Re: gedit 提示错误,有解决方案吗?

#6

帖子 poloshiao » 2016-10-17 12:19

编辑文件提示“Set document metadata failed: 不支持设置属性 metadata::gedit-spell-enabled”错误,
https://bugs.launchpad.net/ubuntu/+sour ... ug/1575484
"Set document metadata failed"
還沒看到 有效的解決方案
头像
ahwad
帖子: 1074
注册时间: 2009-05-06 0:36
送出感谢: 2 次
接收感谢: 13 次

Re: gedit 提示错误,有解决方案吗?

#7

帖子 ahwad » 2017-04-29 16:44

好像从14.04才开始有这样的情况,现在16.04,也这样。安装过17.04,好像也这样。。。。
回复

回到 “LTS 长支持版”