求助,请问ubuntu12最高支持得libc6版本是多少?

为当前最终发行版之前的所有版本提供支持
回复
woshidabendan
帖子: 9
注册时间: 2018-07-11 20:05
系统: ubuntu server 18.04
送出感谢: 1 次
接收感谢: 0

求助,请问ubuntu12最高支持得libc6版本是多少?

#1

帖子 woshidabendan » 2019-11-03 23:19

公司有一台比较老的服务器,ubuntu12.几忘了,安装zabbix-agent提示要把libc6升级到2.17以上目前是2.15,请问可以升级上去吗,怕把系统搞瘫了
头像
astolia
论坛版主
帖子: 4414
注册时间: 2008-09-18 13:11
送出感谢: 1 次
接收感谢: 739 次

Re: 求助,请问ubuntu12最高支持得libc6版本是多少?

#2

帖子 astolia » 2019-11-04 9:40

不要单独升级glibc。12.04已经于2年前停止支持了,做服务器用的话最好还是整体升级到16.04或18.04。
如果实在不能升级,建议用虚拟化技术或容器技术来跑。比如docker的 https://hub.docker.com/r/zabbix/zabbix-agent/
头像
独行猫儿
帖子: 197
注册时间: 2009-02-25 18:07
送出感谢: 5 次
接收感谢: 7 次

Re: 求助,请问ubuntu12最高支持得libc6版本是多少?

#3

帖子 独行猫儿 » 2019-11-04 12:50

astolia 写了:
2019-11-04 9:40
不要单独升级glibc。12.04已经于2年前停止支持了,做服务器用的话最好还是整体升级到16.04或18.04。
如果实在不能升级,建议用虚拟化技术或容器技术来跑。比如docker的 https://hub.docker.com/r/zabbix/zabbix-agent/
Docker同样不能在这种古董版本上运行。

老旧系统就不要干什么新鲜事,什么破公司破需求。
<!--不再参与任何形式的讨论-->
头像
astolia
论坛版主
帖子: 4414
注册时间: 2008-09-18 13:11
送出感谢: 1 次
接收感谢: 739 次

Re: 求助,请问ubuntu12最高支持得libc6版本是多少?

#4

帖子 astolia » 2019-11-04 14:25

独行猫儿 写了:
2019-11-04 12:50
Docker同样不能在这种古董版本上运行。
12.04最后一个hwe内核是3.13,怎么就不能运行docker了?
头像
独行猫儿
帖子: 197
注册时间: 2009-02-25 18:07
送出感谢: 5 次
接收感谢: 7 次

Re: 求助,请问ubuntu12最高支持得libc6版本是多少?

#5

帖子 独行猫儿 » 2019-11-05 10:13

astolia 写了:
2019-11-04 14:25
独行猫儿 写了:
2019-11-04 12:50
Docker同样不能在这种古董版本上运行。
12.04最后一个hwe内核是3.13,怎么就不能运行docker了?
要用hwe么 :Hehe
理论上是没问题啦……理论上。
<!--不再参与任何形式的讨论-->
回复

回到 “老旧版本支持”